Help with flashing Marlin fw via Repetier Server Pro?

edited January 29 in Repetier-Server
I'm on a Pro trial at the moment, and mostly loving it. I'd like to flash an updated version of Marlin to one of my connected printers via USB, but I'm having issues. I can print, send commands, etc., but flashing firmware isn't working. The printer is configured to use serial port: /dev/serial/by-id/usb-FTDI_FT232R_USB_UART_A107QINP-if00-port0 in the Printer Settings menu. When I attempt to flash the firmware, here's what I'm seeing:



Uploading firmware binary ...
Stopping printer connection
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x9c
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0xbe
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0xdb
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x0c
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x20
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x21
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0xdc
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x98
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x98
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x98

avrdude done. Thank you.

Upload finished
Reactivating printer connection ...
Firmware upload finished.




That port is not in use by any other software, and I believe I am using the correct hex file, found in my appdata\local\temp directory. Any ideas?

Comments

  • It is not the hex file. avrdude is not getting the expected response from your printer board. Different boards use different bootloaders so it is important to select the right uploading setting. You did not name the board, so can not say which one is correct. Some boards even need a switch to be removed/inserted to be able to upload. So maybe just try the other uploaders if they work better.
  • I am using a Melzi board, 1284p is the correct value, which is selected. I also tried the Arduino Uno option, but to no avail. The board definitely has a bootloader, and I flash these with no problem using Arduino on a regular basis.

    The printers themselves are connected via a hub, but that serial port is not available on the fw upload screen, just the generic /dev/tty0, etc. ports.
  • I think the melzi board uses the Arduino 1284 or teensy uploader. For compiling you also needed to install special packages as it is not an official arduino. Do you already see 2 Arduino 1284 uploaders? I lately learned there are 2 baud rates used but not sure if I added it for next version or already.

    You can not set port because it uses the same port as set for connection.
  • I have not tried the Teensy uploader, I will do so. I'm running 0.90.7 right now, FYI. Also, my baud rate is (and should be) 115200.
  • Please check for update. Just released 0.91.0 which definitely has 2 uploaders for avr1284. 
Sign In or Register to comment.