RH crashes during print after today's Ubuntu updates to Mono

Ubuntu 14.04 pushed a software update this evening and now prints crash about 2 minutes into the print, with the following not terribly useful looking output:

"Rebuild object False

Unhandled Exception:
System.NullReferenceException: Object reference not set to an instance of an object
  at System.Threading.EventWaitHandle.Reset () [0x00000] in <filename unknown>:0
  at (wrapper remoting-invoke-with-check) System.Threading.EventWaitHandle:Reset ()
  at System.Threading.Timer+Scheduler.SchedulerThread () [0x00000] in <filename unknown>:0
  at System.Threading.Thread.StartInternal () [0x00000] in <filename unknown>:0
[ERROR] FATAL UNHANDLED EXCEPTION: System.NullReferenceException: Object reference not set to an instance of an object
  at System.Threading.EventWaitHandle.Reset () [0x00000] in <filename unknown>:0
  at (wrapper remoting-invoke-with-check) System.Threading.EventWaitHandle:Reset ()
  at System.Threading.Timer+Scheduler.SchedulerThread () [0x00000] in <filename unknown>:0
  at System.Threading.Thread.StartInternal () [0x00000] in <filename unknown>:0"

Not sure which mono packages to pull the version information from, so I went with mono-runtime, but it appeared that basically all the Mono packages got updated.

dpkg -s mono-runtime
Package: mono-runtime
Status: install ok installed
Priority: optional
Section: cli-mono
Installed-Size: 93
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Architecture: amd64
Source: mono
Version: 3.2.8+dfsg-4ubuntu1.1

RH 1.0.6, slicing with Cura.


  • You are right. Does not look very usefull. All backtraced functions are part of System.Threading. which is a mono library part.

    Does it happen every time or was it a one time failure? 

    Were there some more backtraced lines starting with repetier ... that might give a hint where the thread came from.
  • It crashes every time, around the same time.  Just in case I also tried a run with Slic3r and it crashes around the same time.

    Unfortunately that was all the output that appeared in shell.   Is there a way to run it with more verbose output?

  • Ran another test - for reference, it crashed on layer 2 of a 1cm test cube.

    Not sure if this is related, but I realized when launched from the shell it reports an error even if I don't do anything.   Literally, run it from the shell, and click the close button brings up this:

    "Unhandled Exception:
    System.ArgumentException: A null reference or invalid value was found [GDI+ status: InvalidParameter]
      at System.Drawing.GDIPlus.CheckStatus (Status status) [0x00000] in <filename unknown>:0
      at System.Drawing.Graphics.GdipMeasureString (IntPtr graphics, System.String text, System.Drawing.Font font, System.Drawing.RectangleF& layoutRect, IntPtr stringFormat) [0x00000] in <filename unknown>:0
      at System.Drawing.Graphics.MeasureString (System.String text, System.Drawing.Font font, Int32 width, System.Drawing.StringFormat format) [0x00000] in <filename unknown>:0
      at (wrapper remoting-invoke-with-check) System.Drawing.Graphics:MeasureString (string,System.Drawing.Font,int,System.Drawing.StringFormat)
      at System.Windows.Forms.TextRenderer.MeasureTextInternal (IDeviceContext dc, System.String text, System.Drawing.Font font, Size proposedSize, TextFormatFlags flags, Boolean useMeasureString) [0x00000] in <filename unknown>:0
      at System.Windows.Forms.TextRenderer.MeasureText (System.String text, System.Drawing.Font font, Size proposedSize, TextFormatFlags flags) [0x00000] in <filename unknown>:0
      at System.Windows.Forms.ToolStripItem.OnParentChanged (System.Windows.Forms.ToolStrip oldParent, System.Windows.Forms.ToolStrip newParent) [0x00000] in <filename unknown>:0
      at System.Windows.Forms.ToolStripItem.set_Parent (System.Windows.Forms.ToolStrip value) [0x00000] in <filename unknown>:0
      at (wrapper remoting-invoke-with-check) System.Windows.Forms.ToolStripItem:set_Parent (System.Windows.Forms.ToolStrip)
      at System.Windows.Forms.ToolStripItemCollection.Remove (System.Windows.Forms.ToolStripItem value) [0x00000] in <filename unknown>:0
      at System.Windows.Forms.ToolStripItem.Dispose (Boolean disposing) [0x00000] in <filename unknown>:0
      at System.Windows.Forms.ToolStripDropDownItem.Dispose (Boolean disposing) [0x00000] in <filename unknown>:0
      at System.Windows.Forms.ToolStripMenuItem.Dispose (Boolean disposing) [0x00000] in <filename unknown>:0
      at System.ComponentModel.Component.Finalize () [0x00000] in <filename unknown>:0 "

    Just in case that helps.

  • Im having similar issues I see the "rebuild object" error on the terminal side, and it was working fine up until the 23rd on my machine and suddenly after updates were ran, I get random crashes in repetier at random time periods durring my prints.
    Sometimes it prints 10 minutes, sometimes an hour. Suddenly the program crashes and the printer comes to a halt.

    Maybe we can figure out which update caused it.

    Here are the updates from my /var/logs/apt/history.log
    I recieved these on the 24th. Right before mine quit working.
    The mono updates came in today, the 25th.
    Since my repetier died on the 24th I think it was one of these updates, not Mono.
    You probably recieved these as well as Mono all at once. 
  • Start-Date: 2015-03-24  10:55:43
    tzdata-java:amd64 (2015a-0ubuntu0.14.04, 2015b-0ubuntu0.14.04)
    tzdata:amd64 (2015a-0ubuntu0.14.04, 2015b-0ubuntu0.14.04)
    linux-headers-generic:amd64 (,
    libgnutls-openssl27:amd64 (2.12.23-12ubuntu2.1, 2.12.23-12ubuntu2.2)
    libegl1-mesa:amd64 (10.1.3-0ubuntu0.3, 10.1.3-0ubuntu0.4)
    linux-headers-generic-lts-saucy:amd64 (,
    libopenvg1-mesa:amd64 (10.1.3-0ubuntu0.3, 10.1.3-0ubuntu0.4)
    libegl1-mesa-drivers:amd64 (10.1.3-0ubuntu0.3, 10.1.3-0ubuntu0.4)
    linux-generic-lts-saucy:amd64 (,
    libgl1-mesa-dri:amd64 (10.1.3-0ubuntu0.3, 10.1.3-0ubuntu0.4)
    libgl1-mesa-dri:i386 (10.1.3-0ubuntu0.3, 10.1.3-0ubuntu0.4)
    libglapi-mesa:amd64 (10.1.3-0ubuntu0.3, 10.1.3-0ubuntu0.4)
    libglapi-mesa:i386 (10.1.3-0ubuntu0.3, 10.1.3-0ubuntu0.4)
    libgles2-mesa:amd64 (10.1.3-0ubuntu0.3, 10.1.3-0ubuntu0.4)
    linux-generic-lts-trusty:amd64 (,
    libgl1-mesa-glx:amd64 (10.1.3-0ubuntu0.3, 10.1.3-0ubuntu0.4)
    libgl1-mesa-glx:i386 (10.1.3-0ubuntu0.3, 10.1.3-0ubuntu0.4)
    libxatracker2:amd64 (10.1.3-0ubuntu0.3, 10.1.3-0ubuntu0.4)
    linux-headers-generic-lts-trusty:amd64 (,
    libosmesa6:amd64 (10.1.3-0ubuntu0.3, 10.1.3-0ubuntu0.4)
    libosmesa6:i386 (10.1.3-0ubuntu0.3, 10.1.3-0ubuntu0.4)
    libwayland-egl1-mesa:amd64 (10.1.3-0ubuntu0.3, 10.1.3-0ubuntu0.4)
    libgnutls26:amd64 (2.12.23-12ubuntu2.1, 2.12.23-12ubuntu2.2)
    libgnutls26:i386 (2.12.23-12ubuntu2.1, 2.12.23-12ubuntu2.2)
    libgbm1:amd64 (10.1.3-0ubuntu0.3, 10.1.3-0ubuntu0.4)
    linux-libc-dev:amd64 (3.13.0-46.79, 3.13.0-48.80)
    linux-image-generic-lts-saucy:amd64 (,
    linux-image-generic:amd64 (,
    linux-image-generic-lts-trusty:amd64 (,
    linux-generic:amd64 (,
  • I also recieved these as Installs..

    linux-image-extra-3.13.0-48-generic:amd64 (3.13.0-48.80)
    linux-image-3.13.0-48-generic:amd64 (3.13.0-48.80)
    linux-headers-3.13.0-48:amd64 (3.13.0-48.80)
    linux-headers-3.13.0-48-generic:amd64 (3.13.0-48.80)
    libept1.4.12:amd64 (1.0.12, automatic)
    rarian-compat:amd64 (0.8.1-5ubuntu1, automatic)
    librarian0:amd64 (0.8.1-5ubuntu1, automatic)
    synaptic:amd64 (0.81.1ubuntu1)
  • Has anyone resolved this problem yet? I just had to reinstall Kubuntu 14.04, and now my RH crashes during printing as well. It crashes in nearly every print - usually about 3-5 mins in. I tried launching & closing from the cmd-line, and had the same exceptions.
  • Here the solution from a parallel thread:

    In this thread http://forum.repetier.com/discussion/397/rh-started-crashing-after-10-minutes#latesta user found resources showing that you need kernel 3.13.046 to work. Some googling showed that after that some kernal changes seem to have side effects. I do not understand this kernel stuff so can not say what might be all possible crash reasons.

    What you show is more a failed connection as it looks like the serial device could not be found during connection.
  • Is there any update to this?  I am running Linux 17.2 mint, with 3.16.0-38-generic and get the threading issue.  I have tried an older kernel as specified, which would not boot, as well as 4.2 which failed in other ways.

  • Hope this helps someone else.  I tried a different updated kernel (4.1.12), and it seems to be stable for my repetier set-up:

    I installed that, rebooted, selected the newer kernel.  Repetier has run for 1/2 day so far without crashing.  I haven't tested anything else with the new kernel, so upgrader beware.
  • Just a follow up.  Never had a Repetier crash after updating the kernel to 4.1.12 specified above.  I personally didn't see any side effects either for my setup.
Sign In or Register to comment.