Differen Steps/mm on dual extruders

Good Evening,
I can't find the settings for the extruders. The second extruder needs a multiplier of 30-40 for normal extrusion...
And it's not the printer software: IT IS the G-Code.
How can I change the settings?

In the following you can see a part the G-code of the when T1 has a multiplier of 18.
T0 is around E=80 and T1 is around E=55. can you help me?



T0
G92 E0
G1 X113.100 Y102.700 F7200.000
G1 E80.50000 F6000.00000
G1 F672
G1 X113.100 Y102.300 E80.50327
G1 X132.900 Y102.300 E80.66507
G1 X132.900 Y102.700 E80.66834
G1 X113.130 Y102.700 E80.82989
G1 X113.199 Y102.526 F7200.000
G1 X113.187 Y102.500 F7200.000
G1 F1200
G1 X132.813 Y102.500 E81.01397


T1
G92 E0
G1 X87.600 Y102.300 F7200.000
G1 E54.03500 F6000.00000
G1 F672
G1 X67.800 Y102.300 E54.22402
G1 X67.800 Y101.900 E54.22783
G1 X87.600 Y101.900 E54.41685
G1 X87.600 Y102.270 E54.42038
G1 X87.400 Y102.299 F7200.000
G1 X87.513 Y102.100 F7200.000
G1 F1200
G1 X67.887 Y102.100 E54.63543





Comments

  • Yo can set the firmware extruder resolution so both multipliers are the same. How depends on the firmware. For Repetier-Firmware just open eeprom editor and change the value.
  • Yes I know, but that's not the problem... I tested the printer with the command:
    "G1 E100"
    and it extrudes exacly 100 mm.
    But when I slice something it uses far to less material. I checked the diameter and the nozzle-diameter...
  • Is there something I could have changed that I shouldn't have changed?
  • what slicer do you use and do you have same nozzle diameters for both extruders?

  • "G1 E100"
    and it extrudes exacly 100 mm

    Just to make sure

    when you say it extrudes 100mm,  this should be 100mm of filament going into the extruder, not hot filament coming out the nozzle.


  • Is there maybe something that I changed what I shouldn't have changed?
  • Since you did not answer the questions e.g. from MartinH it is hard to say what you did wrong. Also can you explain what you mean with "In the following you can see a part the G-code of the when T1 has a multiplier of 18. 
    T0 is around E=80 and T1 is around E=55. can you help me?"

    Which setting in which software to you refer multiplier to? I assume here you mean slicer so it has 18x extrusion. That would mean your steps per mm in extruder is wrong. From the ratio it could be exactly the error Martin mentioned. You calibrate what goes in not what goes out!
  • Sorry I didn't saw the answer... yes it's the Filament going through the extruder. And it's the same nozzle diameter
    What I meant by "In the following you can see a part the G-code of the when T1 has a multiplier of 18. T0 is around E=80 and T1 is around E=55. can you help me?" is:
    I sliced it with Repetier Host and the Command "E" says how much it will extrude for the line. In this G-Code T0 has the multiplier in the Filamentsettings of 0,85 and T1 18. And for T1 all "E" commands are much lower than for T0... That confuses me.

  • edited January 24
    nm
  • I mean the delta of each "E"-command
  • When I set the first Filament to extr_multiplier to 1 the second nozzle needs a multiplier of 16 for the same amount of material in the G-code...
  • The E values are absolute in your example, so only differences get extruded.
    0.85 is quite normal, 16 absolutely off so your steps per mm in firmware for second extruder must be factor 18 too low.
Sign In or Register to comment.