Dual Extruders won't Center

edited January 19 in Windows

I have changed the X offsets for the extruders in Printer Settings with no effect to the printing position which is to the left of center by 16 mm.

What am I doing wrong?

Comments

  • What printer type do you have? What are the positions you want and what did you enter? Offsets are in steps not mm so make sure to multiply with steps per mm.

    Cartesian printers will always home the same regardless of the left extruders offset. The center would only move.
  • edited January 19

    Thank you for responding so quickly.

     The printer is a GEEETech i3.  The extruder nozzles are 32mm apart in the X direction so I need extruder 1 (left) to be offset by -16mm and extruder 2 (right) to be offset +16mm so they will both start in the center of the printable area.  I have entered large values (-100) for extruder 1 with no change in X or Y position.  I even tried a positive number (+100) with no luck.  I am using version 2.1.3 of Repetier-Host

  • As I said, for cartesian printers it does not matter which offset your left extruder has. Only thing matters is difference between left and right extruder. When you switch extruders they should move so that the new active extruder is over the position of the now inactive extruder. Normally you set left one to 0,0,0 and right one then to 80 steps per mm * 32 mm=2560 steps, assuming 80 steps per mm for x axis. Configuration.h has mm, eeprom has steps as distance and you need to change in eeprom or you won't see a difference. It will always such that at homing position you can switch extruders without hitting the endstop. So you would have at least 32mm distance to the endstop after homing with first extruder active.
  • I found out there are two areas for extruder offsets, one in the config printer settings and the other in the Slic3R program printer settings.  I changed them both to 2560 offset on extruder 2 only in the X direction with NO luck.  I looked on the printer display ( I think you call that the eeprom) to find an offset but when I try to enter into the home offset it quickly goes back to the main screen and beeps at me.

    Is there a G-code that could be sent to the printer to set the X offset in the start after the home G-code?

  • First forget slic3r offsets. Set them to 0! This was added long ago when firmwares did not have extruder offsets. Nowadays firmware handles the offset on it's own. Repetier-Firmware always did it on it's own. Having both just adds trouble and errors.

    Offsets do not get lost when homing. As I said go to eeprom, set offset for left extruder to 0,0 and right to distance*steps per mm. Home and then switch between T0 and T1. You will see that the extruder moves left when selecting second extruder so right nozzle is where left one was. Selecting first extruder reverses it. You will also see you can do that homed to the left side, which is why you get the gap when homing with extruder 1 active. That is how it is supposed to be.

  • Hello Repetier, The problem was that the printer setting for the slic3r somehow got duplicated and I didn't notice the slight difference in the file name so I was editing one file and slicing with an other.  I was able to get the extruder offsets to work by setting both (slic3r and Repetier) printer settings and to be centered on the bed by changing extruder 1 to -32mm and extruder 2 to 0mm.

    I now have a new problem in that the brim extrusion only works for extruder 1.  This causes the first extruded layer from extruder 2 to be all messed up.  I don't see anything in any of the settings to fix this, there is only one setting and it is for extruder 1.  I tried different slicers like Cura and Skeinforge but they don't even have provision for 2 extruders.

  • Set brim extruder to 0 to use the currently active one.
  • With Slic3r, when printing with dual extruders, I can't get extruder 2 to lay down a skirt.  This causes a dead stop in the print every time the extruders are switched.  I will try Cura.
Sign In or Register to comment.