Timelapse with EDIMAX IC-5150 not working

Hello,
I am getting a bit desperate. I am trying to use the timelapse feature but no success.
I am using EDIMAX IC-5150 under Linux Mint.
I configured the camera, I see dynamic and static input from camera in Repetier Server environment.
I also set the rules for interval of taking the pictures needed for timelapse generating.
FFMPEG is installed.
When I start printing the server indicates that it is recording.
After finishing the job there are no stills saved in the directory and therefore generating of the timelapse fails.
Mjpg_streamer is not installed, because this cam supports direct JPG and MJPEG output.In my opinion it is not needed in this case or am I wrong? Honestly,I have no idea what else to check....
Could you help me,please?
Thank you in advance for any help.
Best regards
Martin

Comments

  • In printer configuration you need to check if you see in webcam section the static and motion mjpg. If you don't see them there timelapse will not work. A typical error I often see is that users enter the url where the image appears, but you need the url of the image it self. It is fairly easy to get if you right click on the image in chrome you can also copy the url of the image, which is what you need.

    If that works timelapse will store pictures. So even without ffmpeg you would at least see the pictures. With ffmpeg it will get converted into a mp4 video.
  • edited January 17
    Thank you very much for fast feedback ! I double checked again everything what you recomended me,but no success.
    Everything was okay and preview of static and dynamic worked also, but  timelapse was not working.
    I did some more research and found out that the problem is that I am using the password protected access.
    The link to my static source seems like this:
    http://user:password@192.168.1.20/snapshot.jpg?user=user&pwd=password
    In this case Repetier shows the preview but does not generate any timelapse, because it does not have any captured stills.
    I decided to activate the anonymous access for testing purposes and....BINGO...the timelapse started to work.
    So...the resume seems to be, that Repetier has some problem when using password protected access to the camera.
    I also tried to search something in the Repetier manual, if there is something meant about NOT using the password protected access and found nothing.So,I suspect,that it is a bug.The strange thing is,that in settings I see the preview, but no stills are captured when using NON-anonymous access.
    I don think that using anonymous access is  the solution, it is just workaround, because it would be very useful to use the password protected access.
    Please, let me know your opinion.
    Best regards
    Martin
  • You are right. The timelapse function uses it's own version to grab picture and that was not updated to use the user:password trick. Will fix this for next update.

    Your examples has it double - the problem is only with the user:password@ variant so you can try if the other one alone works (?user=use&pwd=password). My IP webcam supports both.
  • Hello,thank you again for your feedback. I really appreciate it !
    To your note about the syntax for this camera (doubled usr/pass)  - unfortunately the format is correct.
    For this type it really should be doubled like in this example.

    http://user:password@192.168.1.20/snapshot.jpg?user=user&pwd=password

    No other variants are accepted and if there is only part of this code, then manual entering usr/pass is required.
    I tried these variants with no success...
    http://user:password@192.168.1.20/snapshot.jpg - NOT ACCEPTED
    http://192.168.1.20/snapshot.jpg?user=user&pwd=password - NOT ACCEPTED

    Any other ideas?
    Best regards
    Martin
     P.S. The syntax generator for cameras is available here:
    For EDIMAX brand - https://www.ispyconnect.com/man.aspx?n=Edimax#
    The other brands - https://www.ispyconnect.com/sources.aspx
    Very useful resource for the research...
  • No, but next release is nearly finished and there my solution with password hopefully works.

    Link is really good if I someone does not know the link.
Sign In or Register to comment.