Repetier Server on Raspberry Pi 1 with Edimax Wifi Stick


ia am trying to use the Server on an Raspberry Pi 1 with an Edimax Wifi Stick.

In the Settings Menu is under Wifi only the message "This installation does not support Wifi configuration" or sometimes there is just the message that no Wlan Adapter installed.

By typing lsusb i get this result:

Bus 001 Device 004: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp. SMC9512/9514 USB Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

By typing dmesg i get this for about 200 times:

[  551.945773] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

Can anyone tell me what to do???

best regards



  • iwconfig
    should show the state. I have one stick that works not well with our solution a sit can not scan networks and have one connection. Not sure whcih type that was. Aynhow, better first check if linux has it working or not and then see what is wrong.
  • I have installed Raspbian Lite and configured the Wlan, no Problems
    Afterwards i have installed Repetier Server, now it works without Problems, but i can't set it up in Repetier, but this is okay for me....

    Thanks for your Help

  • Now i tried the newest Image.
    If I go to Wifi settings it looks like this:

    It says no adapter installed, but it can find the WLAN's.
    But it is not able to connect...

    Any Idea ?
  • If you send iwconfig, what is the response (linux console)?
    Also what is response on
    sudo ifconfig | grep wlan0

    the answer is used to determine if you have wlan. Maybe it appears as wlan1 instead, then you need to change WLAN in /usr/local/Repetier-Setup/etc/server.conf

  • iwconfig:

    eth0      no wireless extensions.

    lo        no wireless extensions.

    wlan0     unassociated  Nickname:"<WIFI@REALTEK>"
              Mode:Managed  Frequency=2.412 GHz  Access Point: Not-Associated
              Retry:off   RTS thr:off   Fragment thr:off
              Power Management:off
              Link Quality:0  Signal level:0  Noise level:0
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0

    For sudo ifconfig | grep wlan0 there is no answer, just a blank line.

  • pi@FelixWhite:~ $ sudo ifconfig | grep wlan0 

    wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500

    would be what you need so that the network appears.

    Please try connecting manually.

    sudo service RepetierServer stop

    sudo /usr/local/Repetier-Setup/bin/manageWifiAccess connectPW ssid password

    sudo service RepetierServer start

    And see if that works. I guess once you have a connection it also appears as interface.

Sign In or Register to comment.