Klipper connection to CR10S

Hello together,

I was able to install Kliipper on my CR10S.
I also changed the Firmware inside configuration to Klipper. It seems that Repetier Server is connected to the printer but it doesn't start the commands or heating elements. When I try to change the temperature I get the following message:

21:32:03.089: N98 M140 S33
21:32:03.091: // Printer is not ready
21:32:03.091: // The klippy host software is attempting to connect. Please
21:32:03.091: // retry in a few moments.
21:32:03.091: Firmware was halted, trying to reconnect. Eventually running print is stopped.

But the connection color is still green.

printer.cfg:
[mcu]
serial: /dev/serial/by-id/usb-FTDI_FT232R_USB_UART_A1071H3O-if00-port0
baud: 250000
pin_map: arduino

Is there any idea why the printer doesn't react on the commands?

TomBola_

Comments

  • This is more a Klipper then a server problem. Klipper has 2 parts - the server running on the pi which is where our server connects to and that part worked. The other part of klipper is the firmware that runs on the printer motherboard and klipper server is the instance connecting to it. As you see from the message that part is not working correctly. For more informations about this you better check the Klipper homepage/forum.
  • edited January 3
    Found the problem. :)

    It was indeed a Klipper problem. Flashing the firmware showed ok but it really worked only with a different command like this:
    sudo avrdude -v -p atmega2560 -c wiring -P /dev/serial/by-id/usb....(your usb device) -b 57600 -U out/klipper.elf.hex

    This worked for me.

    But now I have another small problem.

    When I do a "normal" file upload it takes a long time after uploading and I can only see a kind of hour glass.
    When I use the direct upload it starts after some seconds of uploading.
    Any idea? I found something about process priority but do not know how to change it.


  • You mean a circle of spinning points appear? That would be the server analysing the gcode. Normally takes only a few seconds and that also happens with direct upload. What browser are you using? Which version and os?
  • The last 4 weeks everything works fine and it needs some seconds or up to 30sec.
    But since 1 week or perhaps since I am trying to install Klipper I can wait more than 10minutes without success.
    Operatiing system Windows 10. Tested with Chrome and Firefox. Cookies enabled.

    If I use the DirectUpload Button it works after some seconds and after heating up the bed and the nozzle.
  • Update.
    I deleted Klipper.  :'(
    Had all the times problems when I connected the 2nd and 3rd printer with Marlin instead of Klipper.
    Now I did an firmware upate to 1.1.19 for the CR10S.
  • Uploading directly or to models does more or less exactly the same operations. So if model upload does not work it might be something in the directory.
    Stop server:
    > sudo service RepetierServer stop
    Go to

    > cd /var/lib/Repetier-Server/printer/<slugname>/models/

    and check files there.

    > ls

    if there is nothing important just delete all:

    >sudo rm 00*

    Also delete work dispatcher file

    > sudo rm 

    /var/lib/Repetier-Server/database/workdispatcher.sql

    and start server again:

    > sudo service RepetierServer start

    Then there are no old jobs waiting to be run and model list is clean in case there is a part causing the block.


    With klipper you should maybe switch to using /dev/serial/by-path so printers get not mixed in order of detection or due to having same id.

  • Wow.
    Thank you for the fast support.
    The folder /var/..../printer/... was empty.
    I deleted file workdispatcher.sql.
    Now everything works fine again! :)

    I got only one warning (since the beginning and only for my Prusa i3 MK3) that every model is bigger than the bed plate. It doesn't matter if I slice with Slic3r or Cura. I also tried to increase the bed size in Repetier Software without success. Now it is bigger than in Cura. But I still get the same message. But this is not really a big problem. Only if you know where is comes from.
    BTW: CR10S and Ender3 do not have this problem and I do not get the message.

  • Prusa slic3r config by default makes a extrusion at y -3, so go to general tab and set y min to -4 there and the message disappears. Had the same problem with my Prusa MK3 :-)
Sign In or Register to comment.