slic3r is generating gcode to turn off extruder and bed at end of print

Slic3r is geneating the following code at the end of the Gcode.

M104 S0 ; set temperature
M140 S0 ; set bed temperature

I do not want to turn the extruder and bed off at the end of a print.
how do I diable this?

Comments

  • In Rh on the right, 
    click 'configuration' to open slic3r 
    then settings- printer settings
    custom g-code

    remove commands from End G-Code
  • There is no custom gcodes
  • It is in printer settings.
  • No.  It appears to be generated by Slic3r.
    Anywhere I have gcode, I have tagged it with text specifying its origin.
    I am using Repetier Host, and Slic3r that comes with it.

  • here is the code generated.

    ( are my comments added to code

    M107 ; disable fan
    ; Filament-specific end gcode    (- this is my tag in my filament specific gcode, whisc is none)
    ;END gcode for filament       

    ;FROM PRINTER END CODE       (- this is my tag in my end gcode)
    G28 X0 Y0 ; home X axis
    M84     ; disable motors

    M104 S0 ; set temperature
    M140 S0 ; set bed temperature
    ; filament used = 1880.3mm (4.5cm3)
    ; total filament cost = 0.0
  • Slic3r - configuration - printer settings - custom g-code
  • Yes it is in the slic3r configuration.
    Click configuration under where it says'slice with slic3r'


  • here is the code generated.

    ( are my comments added to code

    M107 ; disable fan
    ; Filament-specific end gcode    (- this is my tag in my filament specific gcode, whisc is none)
    ;END gcode for filament       

    ;FROM PRINTER END CODE       (- this is my tag in my end gcode)
    G28 X0 Y0 ; home X axis
    M84     ; disable motors

    M104 S0 ; set temperature    <<<<<<<<<<<<<  WHERE IS THIS COMING FROM?
    M140 S0 ; set bed temperature  <<<<<<<<<<<
    ; filament used = 1880.3mm (4.5cm3)
    ; total filament cost = 0.0

  • I have no scripts in the SLIc3R Configuration.
    The scripts I have in the Repetier  end code is commented and shows upas show up as ;FROM PRINTER END CODE

    I am still getting 
    M104 S0 ; set temperature
    M140 S0 ; set bed temperature

    at the end of the gcode!
  • what about the custom g-code in filament settings tab?
  • I have checked the follwing for the offending gcode:
    Repetier Printer Start and End gCode
    Slic3r Configuration Start and End gcode
    Slic3r Configuration Filament Start and End gcode

    I am still getting 
    M104 S0 ; set temperature
    M140 S0 ; set bed temperature
    at the end of the gcode.

    Is there anywhere other than the sclicer itself that could cause this code to exist?
  • edited January 11
    ok, can reproduce the problem but no idea where it´s generated.
    searched also in directories for config files ,without success.
    seems to be automatically generated by slicer , may be for safety .

  • Yes, that is possible. If you have no setup for temperatures slic3r will add it for you so it seems logical it does the same if you do not say how to finish. Normally you want extruder to cool down after after print so it logical it adds that if you did not say anything else.
  • OK,found.
    As long as there are no M104 or M140 commands slicer adds  the M104 S0 and M140 S0.
    if you want to prevent from cooling down you have to set the value you want in the custom end code,that does the trick

    see:
  • So, if I want to stay at the current temperature, what gcode do I put in End Gcode script?
    The temperature is dependent on the filament that is in use.
  • M104 with no parameters works.  eliminates turning off extruder.
Sign In or Register to comment.