Unable to use keyboard and mouse on new install on Raspberry Pi 3B

I downloaded the latest image of Repetier-Server for Raspberry Pi (Repetier-Server-Image_0_90_7_v13) and and put the image on an U10 SD card.  I installed the SD Card on a Pi 3B with a HDMI display and keyboard/mouse HIDs.  I do not have or want to use a touch screen for an input device.  When I powered it up, the boot process went directly to a license screen, but the mouse and keyboard were not working.  I have the ability to edit the config files on the SD card with another Pi.  What do I need to edit and what do I need to change in order to use the keyboard and mouse instead of a touch screen input?


  • In boot directory (also editable in windows)

    pi@FelixWhite:~ $ cat /boot/repetier-image-setup.txt 

    # This file contains some settings that are used to define how the image works. Edit this to easily change

    # The behaviour.

    # If you have a connected display you want to run the x server with chrome in kiosk mode. Just set value to 1.

    # If you have no display, you do want to spare the RAM/CPU usage and not start it. Set value to 0.


    # If your display works like a touchscreen you want to hide the mouse. If you use a mouse set it to 0.


    # You might also need to change config.txt and cmdline.txt depending on hardware you use. Especially config.txt

    # contains the orientation of the display, resolution and more. Default is for an original pi display.

    set HIDE_MOUSE=0
    then mouse should be visible. Keyboard is not used for our surface but you can use it to switch to text console to run linux commands (Alt+1 or Alt+f1) use alt+7 to go back to graphic display.
Sign In or Register to comment.