Setting up Joy-It 3.5" Display

Hey, 

I have been trying half a day now but still cant get it to work. 

I did a fresh install of the Raspberry pi image, connected it to a network cable and a HDMI Display and did follow these instructions: 
http://anleitung.joy-it.net/wp-content/uploads/2017/04/RB-TFT3.2_RB-TFT3.5_Manual_2018-01-24-1.pdf but it didn't work. 
I started looking and found this https://forum.repetier.com/discussion/6014/setting-up-adafruit-3-5-tft-w-repetier-server. Obviously they use different drivers but the idea is basically the same. 

The point I get stuck all the time is point 8: I don't have the 99-fbturbo.conf file. 

the directory looks like this:

pi@Repetier-Server:/usr/share/X11/xorg.conf.d $ ls

10-amdgpu.conf  10-quirks.conf  40-libinput.conf  70-wacom.conf

pi@Repetier-Server:/usr/share/X11/xorg.conf.d $ 

I did look into the problem that could be behind it and tried a few installations like lxde, lightdm, xinit, lxde lxde-core lxterminal lxappearance 
it did create the file but I ended up with a system booting to terminal

I also tried: 
pi@Repetier-Server:~ $ dpkg -s xserver-xorg-video-fbturbo

which gave me the following: 

dpkg-query: package 'xserver-xorg-video-fbturbo' is not installed and no information is available

Use dpkg --info (= dpkg-deb --info) to examine archive files,

and dpkg --contents (= dpkg-deb --contents) to list their contents.

pi@Repetier-Server:~ $ 


anyways - I am frustrated and don't really know where to continue. can anyone help me?


by the way: happy Christmas to all of you!

Comments

  • I tested with our image and

    sudo apt install xserver-xorg-video-fbturbo

    did the trick installing the driver and creating the 99-fturbo file.
    You might need to run
    sudo apt update 
    before using apt to install new packages.

  • ok, that did work out so far! I followed the instructions of the pdf but now it's not booting any longer. It starts and shows me the terminal. 
    Whats wrong now?
  • I just started over to find out when this comes up: 
    it happens after I change  

    Option         "fbdev" "/dev/fb0"

    to

    Option         "fbdev" "/dev/fb1"

    in /usr/share/X11/xorg.conf.d/99-fbturbo.conf

    After changing it back to "fb0" it boots again but to the hdmi output


  • Showing the terminal means it booted. Guess it failed starting x server.
    Login using ssh and enter manually
    export DISPLAY=:0
    startx
    not sure the display setting is required. Now you should see error messages I hope, otherwise they are in /var/log/syslog
    hope these help understanding - or it works.
    I have seen booting stop working after updates so eventually you need to run
    sudo raspi-config
    and set autologin terminal as boot sequence.


  • thanks a lot - it did not work but displayd the following error:

    pi@Repetier-Server:~ $ startx

    xauth:  file /home/pi/.Xauthority does not exist


    X.Org X Server 1.19.2

    Release Date: 2017-03-02

    X Protocol Version 11, Revision 0

    Build Operating System: Linux 4.9.41-v7+ armv7l Raspbian

    Current Operating System: Linux Repetier-Server 4.14.80-v7+ #1161 SMP Mon Nov 12 18:51:43 GMT 2018 armv7l

    Kernel command line: 8250.nr_uarts=1 bcm2708_fb.fbwidth=1920 bcm2708_fb.fbheight=1080 bcm2708_fb.fbswap=1 vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=0x40000000  dwc_otg.lpm_enable=0 console=null root=PARTUUID=79d8630f-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait logo.nologo net.ifnames=0 modules-load=dwc2,g_ether

    Build Date: 18 October 2017  04:55:30PM

    xorg-server 2:1.19.2-1+rpt1+deb9u2 (https://www.debian.org/support

    Current version of pixman: 0.34.0

    Before reporting problems, check http://wiki.x.org

    to make sure that you have the latest version.

    Markers: (--) probed, (**) from config file, (==) default setting,

    (++) from command line, (!!) notice, (II) informational,

    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.

    (==) Log file: "/var/log/Xorg.0.log", Time: Sat Dec 29 10:02:48 2018

    (==) Using system config directory "/usr/share/X11/xorg.conf.d"

    (EE) 

    Fatal server error:

    (EE) no screens found(EE) 

    (EE) 

    Please consult the The X.Org Foundation support 

    at http://wiki.x.org

     for help. 

    (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.

    (EE) 

    (EE) Server terminated with error (1). Closing log file.

    xinit: giving up

    xinit: unable to connect to X server: Connection refused

    xinit: server error

    [1]+  Exit 1                  xinit -- -nocursor 2> /dev/null > /dev/null

    pi@Repetier-Server:~ $ 


    The logfile shows the following:


    [   191.110]

    X.Org X Server 1.19.2

    Release Date: 2017-03-02

    [   191.110] X Protocol Version 11, Revision 0

    [   191.110] Build Operating System: Linux 4.9.41-v7+ armv7l Raspbian

    [   191.110] Current Operating System: Linux Repetier-Server 4.14.80-v7+ #1161 SMP Mon Nov 12 18:51:43 GMT 2018 armv7l

    [   191.110] Kernel command line: 8250.nr_uarts=1 bcm2708_fb.fbwidth=1920 bcm2708_fb.fbheight=1080 bcm2708_fb.fbswap=1 vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=0x40000000  dwc_otg.lpm_enable=0 console=null root=PARTUUID=79d8630f-02 root$

    [   191.110] Build Date: 18 October 2017  04:55:30PM

    [   191.110] xorg-server 2:1.19.2-1+rpt1+deb9u2 (https://www.debian.org/support)

    [   191.110] Current version of pixman: 0.34.0

    [   191.111]    Before reporting problems, check http://wiki.x.org

            to make sure that you have the latest version.

    [   191.111] Markers: (--) probed, (**) from config file, (==) default setting,

            (++) from command line, (!!) notice, (II) informational,

            (WW) warning, (EE) error, (NI) not implemented, (??) unknown.

    [   191.111] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Dec 29 10:02:48 2018

    [   191.111] (==) Using system config directory "/usr/share/X11/xorg.conf.d"

    [   191.112] (==) No Layout section.  Using the first Screen section.

    [   191.112] (==) No screen section available. Using defaults.

    [   191.112] (**) |-->Screen "Default Screen Section" (0)

    [   191.112] (**) |   |-->Monitor "<default monitor>"

    [   191.113] (==) No device specified for screen "Default Screen Section".

            Using the first device section listed.

    [   191.113] (**) |   |-->Device "Allwinner A10/A13 FBDEV"

    [   191.113] (==) No monitor specified for screen "Default Screen Section".

            Using a default monitor configuration.

    [   191.113] (==) Automatically adding devices

    [   191.113] (==) Automatically enabling devices

    [   191.113] (==) Automatically adding GPU devices

    [   191.113] (==) Max clients allowed: 256, resource mask: 0x1fffff

    [   191.113] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.

    [   191.113]    Entry deleted from font path.

    [   191.113] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.

    [   191.113]    Entry deleted from font path.

    [   191.113] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.

    [   191.113]    Entry deleted from font path.

    [   191.113] (WW) The directory "/usr/share/fonts/X11/Type1" does not exist.

    [   191.113]    Entry deleted from font path.

    [   191.113] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.

    [   191.113]    Entry deleted from font path.

    [   191.113] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.

    [   191.113]    Entry deleted from font path.

    [   191.113] (==) FontPath set to:

            /usr/share/fonts/X11/misc,

            built-ins

    [   191.113] (==) ModulePath set to "/usr/lib/xorg/modules"

    [   191.113] (II) The server relies on udev to provide the list of input devices.

            If no devices become available, reconfigure udev or disable AutoAddDevices.

    [   191.113] (II) Loader magic: 0x1fbf40

    [   191.113] (II) Module ABI versions:

    [   191.113]    X.Org ANSI C Emulation: 0.4

    [   191.113]    X.Org Video Driver: 23.0

    [   191.113]    X.Org XInput driver : 24.1

    [   191.114]    X.Org Server Extension : 10.0

    [   191.116] (--) using VT number 2


    [   191.116] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration

    [   191.116] (II) no primary bus or device found

    [   191.116] (II) LoadModule: "glx"

    [   191.116] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so

    [   191.121] (II) Module glx: vendor="X.Org Foundation"

    [   191.121]    compiled for 1.19.2, module version = 1.0.0

    [   191.121]    ABI class: X.Org Server Extension, version 10.0

    [   191.121] (II) LoadModule: "fbturbo"

    [   191.121] (II) Loading /usr/lib/xorg/modules/drivers/fbturbo_drv.so

    [   191.121] (II) Module fbturbo: vendor="X.Org Foundation"

    [   191.121]    compiled for 1.19.2, module version = 0.5.1

    [   191.121]    Module class: X.Org Video Driver

    [   191.121]    ABI class: X.Org Video Driver, version 23.0

    [   191.121] (II) FBTURBO: driver for framebuffer: fbturbo

    [   191.138] (WW) Falling back to old probe method for fbturbo

    [   191.138] (II) Loading sub module "fbdevhw"

    [   191.138] (II) LoadModule: "fbdevhw"

    [   191.139] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so

    [   191.139] (II) Module fbdevhw: vendor="X.Org Foundation"

    [   191.139]    compiled for 1.19.2, module version = 0.0.2

    [   191.139]    ABI class: X.Org Video Driver, version 23.0

    [   191.139] (EE) open /dev/fb1: No such file or directory

    [   191.139] (EE) No devices detected.

    [   191.139] (EE)

    Fatal server error:

    [   191.139] (EE) no screens found(EE)

    [   191.139] (EE)

    Please consult the The X.Org Foundation support

             at http://wiki.x.org

     for help.

    [   191.139] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.

    [   191.140] (EE)

    [   191.173] (EE) Server terminated with error (1). Closing log file.


    I hope this helps finding the error.


  • [   191.139] (EE) open /dev/fb1: No such file or directory

    [   191.139] (EE) No devices detected.

    [   191.139] (EE)

    Fatal server error:

    [   191.139] (EE) no screens found(EE)


    Is the crucial part. You see it wanted to use /dev/fb1 which is what you wanted to achieve if I remember the tutorial right, but that device does not exists so xserver failed. The display driver should have created it. So that is where you need to look. Installation/configuration of display driver.


  • Looks like error is in /usr/share/X11/xorg.conf.d/99-fbturbo.conf

    can you please post the complete Content of this file

  • this is the content of the file: 

      GNU nano 2.7.4   File: /usr/share/X11/xorg.conf.d/99-fbturbo.conf             


    # This is a minimal sample config file, which can be copied to

    # /etc/X11/xorg.conf in order to make the Xorg server pick up

    # and load xf86-video-fbturbo driver installed in the system.

    #

    # When troubleshooting, check /var/log/Xorg.0.log for the debugging

    # output and error messages.

    #

    # Run "man fbturbo" to get additional information about the extra

    # configuration options for tuning the driver.


    Section "Device"

            Identifier      "Allwinner A10/A13 FBDEV"

            Driver          "fbturbo"

            Option          "fbdev" "/dev/fb1"


            Option          "SwapbuffersWait" "true"

    EndSection


  • just took a look at the device, seems to be the waveshare Display.

    I´ll respond later on,when i´m at home

  • Hope your internet connection is faster than mine ,
    download the waveshare image and try this . if that works for your display i can help you setting up the repetier image
    for your display.


  • edited January 3
    BTW if you ask for the "WHY" i suggest the waveshare image :
    if you open the joy-it  overlay file ( .dtb) with a text editor you´ll find :

      /waveshare35a_pins         '  :/fragment@2/__overlay__/waveshare35a@0        *  G/fragment@2/__overlay__/waveshare35a-ts@1    

    so i guess it´s just a re-labeled waveshare display ;-) and the image from joy-it seems to be for the hdmi version
  • edited January 4
    Wonderful! The Image works  ;)

    You followed the instructions described in the link above or did you do it differently?


  • you can follow the above instructions

    not shure about the adafruit driver, but it might be compatible ;-)

    if not in Step2 just use your driver instead

    dtoverlay=pitft35-resistive,rotate=90,speed=20000000,fps=20

    change
    dtoverlay=yourdriver,rotate=90,speed=20000000,fps=20


    just let me know the result






  • Step 1: Install latest RPi version of Repetier Server following normal directions

    Step 2: Edit config.txt file 


    Edit Config.txt file on Boot


    Change LCD rotate to 0


    lcd_rotate=0


    Scroll to this section and make these changes, uncomment 3 lines and single line addition


    # Uncomment some or all of these to enable the optional hardware interfaces

    dtparam=i2c_arm=on

    dtparam=i2s=on

    dtparam=spi=on

    dtoverlay=pitft35-resistive,rotate=90,speed=20000000,fps=20


    Save txt file


    Step 3: Eject MicroSD card and load up the PI as normal


    Step 5: SSH into your pi


    Step 6: Expand the filesystem


    sudo raspi-config


    Select: 7 Advanced Options => A1 Expand Filesystem


    Reboot


    Step 7: 

    wget http://www.waveshare.com/w/upload/0/00/LCD-show-170703.tar.gz

    tar xvf LCD-show-*.tar.gz

    cd LCD-show/

    chmod +x LCD35-show

    ./LCD35-show


    —> after this step the Pi reboots showing the terminal but doesn’t start the repetier server


    Step 8: Modify screen config


    /usr/share/X11/xorg.conf.d/99-fbturbo.conf shows the following: 


    Section "Device"

            Identifier      "Allwinner A10/A13 FBDEV"

            Driver          "fbturbo"

            Option          "fbdev" "/dev/fb1"


            Option          "SwapbuffersWait" "true"

    EndSection


    (which I did not change as I assume the settings are right since the display is working)


    step 9: I did skip it as screen size seems to be right




    when trying to start x I get the following message:


    pi@Repetier-Server:~ $ startx

    xauth:  file /home/pi/.Xauthority does not exist



    X.Org X Server 1.19.2

    Release Date: 2017-03-02

    X Protocol Version 11, Revision 0

    Build Operating System: Linux 4.9.41-v7+ armv7l Raspbian

    Current Operating System: Linux Repetier-Server 4.14.80-v7+ #1161 SMP Mon Nov 12 18:51:43 GMT 2018 armv7l

    Kernel command line: 8250.nr_uarts=1 bcm2708_fb.fbwidth=640 bcm2708_fb.fbheight=480 bcm2708_fb.fbswap=1 vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=0x40000000  dwc_otg.lpm_enable=0 console=tty1 console=ttyS0,115200 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline rootwait fbcon=map:10 fbcon=font:ProFont6x11 logo.nologo

    Build Date: 18 October 2017  04:55:30PM

    xorg-server 2:1.19.2-1+rpt1+deb9u2 (https://www.debian.org/support

    Current version of pixman: 0.34.0

    Before reporting problems, check http://wiki.x.org

    to make sure that you have the latest version.

    Markers: (--) probed, (**) from config file, (==) default setting,

    (++) from command line, (!!) notice, (II) informational,

    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.

    (==) Log file: "/var/log/Xorg.0.log", Time: Fri Jan  4 16:48:18 2019

    (==) Using system config directory "/usr/share/X11/xorg.conf.d"

    (EE) 

    Fatal server error:

    (EE) no screens found(EE) 

    (EE) 

    Please consult the The X.Org Foundation support 

    at http://wiki.x.org

     for help. 

    (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.

    (EE) 

    (EE) Server terminated with error (1). Closing log file.

    xinit: giving up

    xinit: unable to connect to X server: Connection refused

    xinit: server error

    pi@Repetier-Server:~ $ 



    logfile shows the following:



    [   527.968]

    X.Org X Server 1.19.2

    Release Date: 2017-03-02

    [   527.968] X Protocol Version 11, Revision 0

    [   527.968] Build Operating System: Linux 4.9.41-v7+ armv7l Raspbian

    [   527.968] Current Operating System: Linux Repetier-Server 4.14.80-v7+ #1161 SMP Mon Nov 12 18:51:43 GMT 2018 ar$

    [   527.968] Kernel command line: 8250.nr_uarts=1 bcm2708_fb.fbwidth=640 bcm2708_fb.fbheight=480 bcm2708_fb.fbswap$

    [   527.969] Build Date: 18 October 2017  04:55:30PM

    [   527.969] xorg-server 2:1.19.2-1+rpt1+deb9u2 (https://www.debian.org/support)

    [   527.969] Current version of pixman: 0.34.0

    [   527.969]    Before reporting problems, check http://wiki.x.org

            to make sure that you have the latest version.

    [   527.969] Markers: (--) probed, (**) from config file, (==) default setting,

            (++) from command line, (!!) notice, (II) informational,

            (WW) warning, (EE) error, (NI) not implemented, (??) unknown.

    [   527.969] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Jan  4 16:48:18 2019

    [   527.970] (==) Using system config directory "/usr/share/X11/xorg.conf.d"

    [   527.973] (==) No Layout section.  Using the first Screen section.

    [   527.973] (==) No screen section available. Using defaults.

    [   527.973] (**) |-->Screen "Default Screen Section" (0)

    [   527.973] (**) |   |-->Monitor "<default monitor>"

    [   527.974] (==) No device specified for screen "Default Screen Section".

            Using the first device section listed.

    [   527.974] (**) |   |-->Device "Allwinner A10/A13 FBDEV"

    [   527.974] (==) No monitor specified for screen "Default Screen Section".

            Using a default monitor configuration.

    [   527.974] (==) Automatically adding devices

    [   527.974] (==) Automatically enabling devices

    [   527.974] (==) Automatically adding GPU devices

    [   527.974] (==) Max clients allowed: 256, resource mask: 0x1fffff

    [   527.974] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.

    [   527.974]    Entry deleted from font path.

    [   527.974] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.

    [   527.975]    Entry deleted from font path.

    [   527.975] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.

    [   527.975]    Entry deleted from font path.

    [   527.975] (WW) The directory "/usr/share/fonts/X11/Type1" does not exist.

    [   527.975]    Entry deleted from font path.

    [   527.975] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.

    [   527.975]    Entry deleted from font path.

    [   527.975] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.

    [   527.975]    Entry deleted from font path.

    [   527.975] (==) FontPath set to:

            /usr/share/fonts/X11/misc,

            built-ins

    [   527.975] (==) ModulePath set to "/usr/lib/xorg/modules"

    [   527.975] (II) The server relies on udev to provide the list of input devices.

            If no devices become available, reconfigure udev or disable AutoAddDevices.

    [   527.975] (II) Loader magic: 0x1fbf40

    [   527.975] (II) Module ABI versions:

    [   527.975]    X.Org ANSI C Emulation: 0.4

    [   527.975]    X.Org Video Driver: 23.0

    [   527.975]    X.Org XInput driver : 24.1

    [   527.975]    X.Org Server Extension : 10.0

    [   527.979] (--) using VT number 2


    [   527.979] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling lo$

    [   527.979] (II) no primary bus or device found

    [   527.979] (II) LoadModule: "glx"

    [   527.980] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so

    [   527.988] (II) Module glx: vendor="X.Org Foundation"

    [   527.988]    compiled for 1.19.2, module version = 1.0.0

    [   527.988]    ABI class: X.Org Server Extension, version 10.0

    [   527.988] (II) LoadModule: "fbturbo"

    [   527.989] (WW) Warning, couldn't open module fbturbo

    [   527.989] (II) UnloadModule: "fbturbo"

    [   527.989] (II) Unloading fbturbo

    [   527.989] (EE) Failed to load module "fbturbo" (module does not exist, 0)

    [   527.989] (EE) No drivers available.

    [   527.990] (EE)

    Fatal server error:

    [   527.990] (EE) no screens found(EE)

    [   527.990] (EE)

    Please consult the The X.Org Foundation support

             at http://wiki.x.org

     for help.

    [   527.990] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.

    [   527.990] (EE)

    [   527.991] (EE) Server terminated with error (1). Closing log file.



    so I tried:


    sudo apt update 

    sudo apt install xserver-xorg-video-fbturbo


    and a reboot 


    —> didn’t change anything….


    I ordered a waveshare display on Amazon which should arrive later or tomorrow and I’ll give it a try, but don’t expect to mich of it jet


    maybe we are closing in on the mistake and can solve it soon



    I did look into the config.txt file afterwards which shows the following now: 


    dtparam=i2c_arm=on

    #dtparam=i2s=on

    dtparam=spi=on

    enable_uart=1

    # Uncomment this to enable the lirc-rpi module

    #dtoverlay=lirc-rpi


    but I’m not sure what to use as „yourdriver“ in 

    dtoverlay=yourdriver,rotate=90,speed=20000000,fps=20

  • oops...
    why don´t you look at the config.txt of the waveshare image? 

    the correct driver is written there as it works....


    fbturbo.conf...

    same there.
    run sudo nano /usr/share/X11/xorg.conf.d/99-fbtrubo.conf  on waveshare image
    so you see the content you need at repetier image
  • the files were all the same but I found the mistake

    without installing xserver-xorg-video-fbturbo it wont boot but installing it changes the fb1 to fb0 again i had to change it again or run the installations in another order

    Thank you both for your help!

    I'll be posting a tutorial in a few minutes for everyone trying to do the same thing

  • Instructions for using a JoyIt or Waveshare 3.5" Display on a RaspberryPi with the Repetier Server Image

    Thank you to RAyWB and codiac2600 for their Tutorial and their help


    1. Copy the Repetier Server image to MicroSD using balenaEtcher (or any other way you like)

    2. Eject MicroSD card (or mount the „boot“ partition and skip step 3)

    3. Reinsert MicroSD card

    4. In „boot“ partition edit the „config.txt“

    Change LCD rotate to 0

    lcd_rotate=0

    Scroll to this section and make these changes, uncomment the 3 lines and the last line addition

    # Uncomment some or all of these to enable the optional hardware interfaces

    dtparam=i2c_arm=on

    dtparam=i2s=on

    dtparam=spi=on

    dtoverlay=pitft35-resistive,rotate=90,speed=20000000,fps=20

    Save txt file

    5. Eject MicroSD card and load in the PI as normal

    6. SSH into your pi (ssh pi@"ip-adress")

    7. Expand the filesystem

    sudo raspi-config

    Select: 7 Advanced Options -> A1 Expand Filesystem -> Finish

    Reboot

    8. SSH into your pi again

    9. Get Updates

    sudo apt update

    10. Install another package

    sudo apt install xserver-xorg-video-fbturbo

    11. Download and install LCD Drivers (each line is a separate command)

    wget http://www.waveshare.com/w/upload/0/00/LCD-show-170703.tar.gz

    tar xvf LCD-show-*.tar.gz

    cd LCD-show/

    chmod +x LCD35-show

    ./LCD35-show


    after the last command the pi automatically reboots and everything should be working



  • I have the same Joy-it display. Been trying the past days to get it working the way I want, removed everything and restarted a couple of times.
    The problem is, when I use the function ./LCD35-show my Picam stops working.
    I set everything up in the repetier server before following these steps to make sure the cam is functional. Everything is working fine. However, after following these steps the Cam is nowhere to be found on the server, I then also tried to set it up using: https://www.repetier-server.com/setting-webcam-repetier-server-linux/
    But that also doesn't work. 
    Can anyone help me on how I can get both the Picam and the Joy-it display working?
  • Before fiddeling with any script just run a test if cam is enabled in linux:

    pi@Repetier-Server:~ $ vcgencmd get_camera

    supported=1 detected=1

    Only if detected is 1 the scripts will activate it. If not detected the script managed to deactivate it somehow.

    Run sudo raspi-config go to Interfacing Options -> Camera to enable it again. Hopefully the function then enables it again.
  • Perfect that was it, after the last script the camera is changed to
    supported=0 detected=0.
    Editing in raspi-config allowed me to activate it again!

    Thank you for the quick response, one more thing I'm running into is the fact that I can not seem to rotate the display upside-down, I've tried pretty much everything possible in boot/config.txt (lcd_rotate=2, lcd_rotate=0, display_rotate, editing the rotate= line) but the orientation of the display does not change.
  • edited September 9
    if you installed the screen as written above you have to change rotation in config.txt this line :

    dtoverlay=pitft35-resistive,rotate=90,speed=20000000,fps=20


  • That is what I was thinking as well. However, after downloading and installing the LCD drivers (Step 11.) that line also disappears from the config.txt. I have tried placing it back in the config and editing the values, but this has no effect at all. My guess is that the line is moved to and read from another location when installing the LCD drivers. I do not have a clue where to find it though.
  • edited September 11
    can you share a copy of your config.txt?

  • edited September 12
    Here it is: 

    # For more options and information see
    # Some settings may impact device functionality. See link above for details

    # uncomment if you get no picture on HDMI for a default "safe" mode
    #hdmi_safe=1

    # uncomment this if your display has a black border of unused pixels visible
    # and your display can output without overscan
    #disable_overscan=1

    # uncomment the following to adjust overscan. Use positive numbers if console
    # goes off screen, and negative if there is too much border
    #overscan_left=16
    #overscan_right=16
    #overscan_top=16
    #overscan_bottom=16

    # uncomment to force a console size. By default it will be display's size minus
    # overscan.
    #framebuffer_width=1280
    #framebuffer_height=720

    # uncomment if hdmi display is not detected and composite is being output
    hdmi_force_hotplug=1
    lcd_rotate=0        (tried it with and without this line, also tried all possible values, but that did not change anything)
    # uncomment to force a specific HDMI mode (this will force VGA)
    #hdmi_group=1
    #hdmi_mode=1

    # uncomment to force a HDMI mode rather than DVI. This can make audio work in
    # DMT (computer monitor) modes
    #hdmi_drive=2

    # uncomment to increase signal to HDMI, if you have interference, blanking, or
    # no display
    #config_hdmi_boost=4

    # uncomment for composite PAL
    #sdtv_mode=2

    #uncomment to overclock the arm. 700 MHz is the default.
    #arm_freq=800

    # Uncomment some or all of these to enable the optional hardware interfaces
    dtparam=i2c_arm=on
    #dtparam=i2s=on
    dtparam=spi=on
    dtoverlay=pitft35-resistive,rotate=90,speed=20000000,fps=20   (added this line later to see if it has an impact, but it does nothing no matter what value I use)
    enable_uart=1
    # Uncomment this to enable the lirc-rpi module
    #dtoverlay=lirc-rpi

    # Additional overlays and parameters are documented /boot/overlays/README

    # Enable audio (loads snd_bcm2835)
    dtparam=audio=on
    dtoverlay=waveshare35a
    #dtoverlay=ads7846,cs=1,penirq=17,penirq_pull=2,speed=1000000,keep_vref_on=1,swapxy=1,pmax=255,xohms=60,xmin=200,xmax=3900,ymin=200,ymax=3900
    start_x=1
    gpu_mem=128

  • edited September 12
    remove this line :(back to start)
    dtoverlay=pitft35-resistive,rotate=90,speed=20000000,fps=20   (added this line later to see if it has an impact, but it does nothing no matter what value I use)

    modify this line:

    dtoverlay=waveshare35a

    to:

    dtoverlay=waveshare35a,rotate=90 


    think that should do the trick
  • edited September 14
    I tried doing that, and any value for rotate=x, but sadly that still does not change anything. (really appreciate the help by the way)
    After some extra attempts, reopening some lines and making sure everything was correctly written, it now works with rotate=270, thank you so much for the help!
Sign In or Register to comment.