Big problem with raft and brim

I am using RH 2.1.3 with Win10. When I slice with CuraEnginer it doesn't do the brim or raft. Whith Slic3r there are no problems but i prefer Cura.


  • You need to select the correct adhesion type under Printer Settings on the right side window when in the Slicer tab.
    Also define the parameters for them while in Configuration for the CuraEngine under the Print - Structure tab settings.
  • I selected brim (and raft) adhesion type and tried different parameters for them in Configuration and nothing. It doesn't generate brim or raft
  • Check your settings in curaengine config->structures. You need to have definition for raft/brim. E.g. brim width=0 will not create brim even if you enable it.
  • brim width is 10
  • Same as I have and setting adhesion type to brim created it for me. Internally it computes the lines by dividing brim width/nozzle diameter. You can set it in printer settings->Extruder or extrusion in curaengine. Make sure one of them has 0.4 or what ever your nozzle size is.
  • Yes the nozzle diameter is 0.4 and it is set 0.4. I tried on my old computer and there everything is fine with the same settings. I am trying to understand where is the problem. Wrong driver?
  • I am wondering if Win10 put your config files in a different place. I am using Win 7 and it put them under a subdirectory of my <working directory> as set up in preferences called <my working directory> / RepetierLogFiles/CuraEngine/<my printer name>/print 
     I have dual boot.
    On my Win 10 boot it put them under <my working directory>/CuraEngine/default/print.
    So my Win7 and my Win 10 do have them in different places. But both programs access them fine. It might be a place to look.
  • On my Win 10 boot it put them under <my working directory>/CuraEngine/default/print and?
  • edited December 2018
    <my working directory>/CuraEngine/default/print      that is the directory path to the config files for CuraEngine.
    <my working directory> is replaced by the name of the working directory you have set up in preferences , whatever that might be.
    I checked for the file locations by making a configuration file in CuraEngine and naming it snappy. Then I just searched for that file name in the search window on the main windows screen. In that subdirectory was the default.ini and the snappy.ini file.
    I don't know what else to tell you.
  • Where i should place default.ini file? Now is in C:\Users\Teodor\AppData\Local\RepetierHost\CuraEngine\default\print

  • edited December 2018
    I guess the real question is: What is your working directory? I did not "put" a file anywhere. I was just pointing out where my config files were found. They were put there automatically by the program. I had specified a working directory in Repetier Host under Config - Preferences - Basic Settings. Mine was just an example of where my files were found. The files were placed there automatically. You might want to create a configuration in CuraEngine and save it, then select that file and try slicing.
  • I am saving my configuration on default file and it can't generate brim or raft with Cura engine slicing. I am doing the same things on the other computer and everything is working fine there. 
  • I'm sorry I have no answer. Reinstall RH ?
  • I have reinstalled RH several times. I will try to reinstal Win10 later. Thank you
  • Reinstalling does not delete configs. They are in <workdirectory>/CuraEngine/<printername> and it's subdirectories print and filament. Try saving them with a different name then default and see if they are there. Instead of reinstalling you could also just delete the CuraEngine folder in work dir and restart host. That is all what matters. It only calls curaengine so there is nothing a new os would help with.
  • I installed RH 4 days ago and CuraEngine can't do rafts and brim since then with default settings, so i think deleting configs will not help me. I suspect some drivers which i installed before RH or GPU driver... 
Sign In or Register to comment.