Problem Connecting Repetier Host to Printer

edited December 2018 in Windows
Windows 10
Downloaded Repetier Host for the first time ~ 12/2/2018.

I do not understand how to do make this work. I'm very new with Repetier Host, 1 week. I've used the SD card to print and now wish to use the USB port to print. I have configured the Printer Settings. 

It does not detect the Maker Select 3D V2 printer. Do I need to install a driver? If so how is this done?


  • I made the connection but the Repetier Host V 2.3.1 Print Preview & Manual Control do not highlight indicating it is not connected. I want to control the printer from this computer and not the internet. How can the local Repetier Host be used and not the web page? 
  • Sounds like you also installed repetier-server. It is not in the internet until you make your pc port 3344 visible to the internet. Until then it is only in your local intranet. Printe rover server is just one option - you can also connect directly from host to printer. You need to make sure that the server is then not connected to the printer as only one program can connect to printer. So deactivate in server and then switch in host from repetier-server connector to serial connector. Make sure baud rate matches and activate log to see what is going on for more informations. 

    Preview is undependent from connection. It just shows the sliced model and can always be selected. Manual control buttons are not selectable if no real connection is there. E.g. connected with server but server not having a printer connection.
  • Thanks, I got it working following your instructions. Being new to this tool it was a bit of a challenge to find the various menus and selections to make. I think the following will help other new users. Some of us need to hand held through the process :) like a child on a busy street. :)

    The process I followed to get the local Host-Repetier printer serial port working:
       Connect serial port to printer and power on your printer if not already running
       In browser window find "deactivate printer" and click it. This will result in a browser message "Connection Lost"
       In the Repetier-Host "Server" drop down menu select "Stop Local Server"
       Then make sure in Repetier-Host "Printer Settings" to select the printer profile for your printer (if not done already fill it in now), press okay
       Then close Repetier-Host program and start it again.
       The manual control should now read "Idle" (not Disconnected)

Sign In or Register to comment.