Print stops after a few seconds

Running Repetier-host connected to a smoothieware board. Got everything calibrated, started my first print (20mm cube), and it stopped after a few seconds of printing. Not only did the print freeze, but repetier host froze as well, all controls useless. Had to hit the reset button on my board and reconnect.

I figured it was a slicing problem, so I tried re-slicing, and even switching between Slic3r and CuraEngine, but both have the same problem. And it stops at a different point each time. Sometimes it starts the perimeter, sometimes it doesn't even finish the brim. So it sounds like a Repetier problem.

Any ideas what could be happening?


  • edited December 2018
    Similarly, every once in a while, a manual command goes awry. Once I sent a manual command to increase Z by 1mm, but it just kept going and going until I hit reset on the board.

    This is the last few lines of Gcode in the file before the last failure: 
    G1 X48.795 Y94.956 E7.78496
    G1 X48.376 Y94.660 E7.81928
    G1 X47.890 Y94.259 E7.86130
    G1 X47.522 Y93.906 E7.89541
    G1 X47.103 Y93.440 E7.93727
    G1 X46.681 Y92.882 E7.98396
    G1 X46.431 Y92.493 E8.01489
    G1 X46.191 Y92.061 E8.04789
    G1 X45.956 Y91.565 E8.08458
    G1 X45.777 Y91.107 E8.11744
    G1 X45.649 Y90.716 E8.14491

    I know enough to know there's nothing funky going on there.

    This is what was in the log for those same lines:
    17:49:34.589 : N168 G1 X48.795 Y94.956 E7.78496*110
    17:49:34.589 : N169 G1 X48.376 Y94.660 E7.81928*98
    17:49:34.589 : ok
    17:49:34.589 : N170 G1 X47.890 Y94.259 E7.86130*110
    17:49:34.602 : ok
    17:49:34.604 : ok
    17:49:34.616 : ok
    17:49:34.618 : ok
    17:49:34.628 : ok
    17:49:34.630 : ok
    17:49:34.643 : ok
    17:49:34.644 : ok
    17:49:34.644 : N171 G1 X47.522 Y93.906 E7.89541*96
    17:49:34.644 : N172 G1 X47.103 Y93.440 E7.93727*98
    17:49:34.644 : N173 G1 X46.681 Y92.882 E7.98396*105
    17:49:34.651 : ok
    17:49:34.652 : ok
    17:49:34.665 : ok
    17:49:34.666 : N174 G1 X46.431 Y92.493 E8.01489*109
    17:49:34.666 : N175 G1 X46.191 Y92.061 E8.04789*108
    17:49:34.666 : N176 G1 X45.956 Y91.565 E8.08458*110
    17:49:34.666 : ok
    17:49:34.676 : ok
    17:49:34.677 : ok
    17:49:34.689 : ok
    17:49:54.437 : N177 M117 ETE 41m 56s*73
    17:49:54.437 : N178 M105*41
    17:49:54.437 : N179 G1 X45.777 Y91.107 E8.11744*106
    17:49:54.437 : N180 G1 X45.649 Y90.716 E8.14491*105

    I don't know what some of those commands are. But anyway, that last line is the last one sent before failure. But again, it fails somewhere different each time. Just thought some code might be of use.

  • M117 is sending times to display. That is the first command not getting a response so maybe smoothieware has problem with this. You can disable sending the M117 in host. Disable the Printer option "Send ETA to printer display" to remove it and retest.
  • That seems to have done the trick - thanks! Though at the same time I tried printing off the SD card, so maybe it was a communications error.
  • Also parallel communication from sd card and host should work it is not a good idea to have 2 prints running the same time.
Sign In or Register to comment.