DaVinci 1.0A repetier firmware upgrade problems

I can't seem to get Windows to recognize the DaVinci1.0A.  I compiled the firmware OK, but was unable to get it downloaded to the printer, as (apparently) windows couldn't recognize the USB connection.  I saw a vague reference somewhere that windows users might need new drivers, but I can't seem to find the specifics on this.  I'd appreciate any insights or advice on how to fix this. Right now my printer is a large doorstop.


  • Check in hardware manage rif you see a com port appear if you connect printer. If not you are in deed missing the driver. I'd guess that installing the original davinci host software should include installing the driver.
  • No com port appears.  Tried removing xyzprinter software and reinstalling, but nothing changed, still doesn't recognize the printer.  Tried linux Mint, but lsusb didn't show the printer either.  Is it possible that I've fried the board during the reset process??  One other possibility I'm going to try.  I have a serial port on my pc, and I'll use a serial to USB converter.  Waiting on a USB gender bender...hurry up Amazon!
  • Well linux normally (if serial support was enabled) supports all usb serial devices, so if it does not show up in //dev/serial/by-id/ that is a bad sign,
  • Not sure if serial support was enabled on my linux machine, but think it was.  I looked in /dev/serial/by-id/ and found a device that I knew was connected, implying I guess that serial support is enabled.  But no 3D printer.  I'm kinda thinking that something happened during the "reset" process.  So, I think I'll look around for a replacement controller.
  • JackCG, 

    I had the hardest time getting my DaVinci to flash.  It's a 1.0, but this should still apply.  After troubleshooting for a freaking week, I figured out that the issue was because it was plugged into a USB hub.  Not sure if this applies to you or not, but they have to be directly plugged into the computer flashing them.
Sign In or Register to comment.