RPi server not connecting to Arduino DUE (RADDS)

edited November 17 in Repetier-Server
Hi All,

I've got a setup which has been working the past year but I'm upgrading the printer, so a month ago I disconnected everything and wired it all up again. 
But right now my RPi 3 does not want to connect to the arduino DUE anymore.
I've tried a new server installation, reuploaded firmware, i also had another due which I tried.
Always the same result.

On the windows PC rep-host it works for a second and then says 1 command waiting.
I also used multiple different usb cables, removed everything so I now only have the Raspberry and the arduino due connected (no radds) but still the same result.

Rep-server does connect to a spare RAMPS 1.4 board I had laying around without issues.

This is a screengrab from the server screen:


And this is the connection log:
<  9:33:44.217: N11 M105
<  9:33:45.226: N12 M105
<  9:33:46.216: N0 M110 N0
<  9:33:46.216: N1 M105
<  9:33:46.216: N2 M115
<  9:33:46.216: N3 M220 S100
<  9:33:46.216: N4 M221 S100
<  9:33:46.216: N5 M355
<  9:33:46.216: N6 G92 E0
<  9:33:46.217: N7 M114
<  9:33:46.217: N8 G90
<  9:33:46.217: N9 M111 S6
<  9:33:46.217: N10 M360
<  9:33:55.233: N11 M105
<  9:33:56.242: N12 M105
<  9:33:57.232: N0 M110 N0
<  9:33:57.232: N1 M105
<  9:33:57.232: N2 M115
<  9:33:57.232: N3 M220 S100
<  9:33:57.232: N4 M221 S100
<  9:33:57.232: N5 M355
<  9:33:57.233: N6 G92 E0
<  9:33:57.233: N7 M114
<  9:33:57.233: N8 G90
<  9:33:57.233: N9 M111 S6
<  9:33:57.233: N10 M360
<  9:34:06.248: N11 M105
<  9:34:07.257: N12 M105
<  9:34:08.246: N0 M110 N0
<  9:34:08.246: N1 M105
<  9:34:08.246: N2 M115
<  9:34:08.247: N3 M220 S100
<  9:34:08.247: N4 M221 S100
<  9:34:08.247: N5 M355
<  9:34:08.247: N6 G92 E0
<  9:34:08.247: N7 M114
<  9:34:08.247: N8 G90
<  9:34:08.247: N9 M111 S6
<  9:34:08.247: N10 M360
Firmware is Repetier 1.0.3

Please help :)

Comments

  • as EEProm is located on RADDS you have to Plug RADDS Board on Due to test connection.

    so may be you try again with RADDS on DUE
  • RAyWB said:
    as EEProm is located on RADDS you have to Plug RADDS Board on Due to test connection.

    so may be you try again with RADDS on DUE
    Still the same problem, It also started while I had the due and radds connected. but just to be sure I just assembled it again and tested it.
    Thanks though
  • btw: I see it stops at M105, get extruder temp.. Can that be an indicator?
  • might be wrong baud rate, what happens when you connect from computer via repetier host directly?
    Interesting part is directly after printer startup

  • edited November 17

    A video of the connection to REP host, with the RADDS on the DUE

    PS: Baud rate is correct, I've always used 115200

    This is the line sent after the one in the video
    15:42:32.729 : Communication timeout - reset send buffer block


  • Host is not connected. You see host never receives a byte from firmware.

    So either baud rate is wrong or you are on the wrong serial port of the due (due has 2) but only one normally responds. Server will most likely have same problem.
  • I used to use the programming ports on the due, but due to your comment I also tried the native port, no difference.
    I reflashed the right baud rate, it's lighting up and the com-port is right. but rep-host just doesn't see it.

    Maybe the arduino is broken but i tried another one with the exact same results.
  • Some more info: I also tried uploading a simple serial loop sketch to arduino. But on both due's only the RX lights up. Which is really weird because why would it be receiving but not sending?
    I also tried repetier 0.92.9 but with the same results.
  • Does uploading include verify in your case? That would also require read and write over the port.

    For firmware you could change eeprom mode to ensure it is set to the right value in case something got wrong with the switches.
  • Yes it does verify completely but even during verifying the TX light doesnt blink. I will try to make a video today of all the steps i took. Also by showing the boards
  • So... Somehow after rechecking everything and uploading the firmware again, suddenly my boards were working.
    On one of the boards I did notice that the TX light was burnt, but that one works now as well. Sorry to have kept you busy! Thanks for your time...
Sign In or Register to comment.