Import zip file into Projects

edited October 2018 in Bug Reports
Repetier Server 0.90.7 Raspberry Pi 3

I create a zip archive of a set of files including STL's and gcode's on my MacBook Pro High Sierra

From within Safari I click the Projects icon and then import Zip and select my earlier created Zip Archive. the file uploads but when done uploading and processing of files all preview pictures are grey and the file size of all files is 0kb's

I did the same as above but in chrome and got the same result.

uploading each file one by one uncompressed works as expected.


  • Have you tried with zips downloaded from thingiverse? Maybe you are using a unsupported compression algorithm for your zip. We have testen thingiverse and youmagine zip files and they all imported well, so that would be a good first test.
  • I downloaded a zip archive from Thingiverse and imported the zip archive and it imported as expected.

    I then Zipped the same folder of files I had previously compressed and tried to import using the OS X GUI context menu However this time I did it from the command line using

    zip -r ~/<locationOffilesToZip>

    I then Imported the Zip file produced by the above terminal command and it imported as expected.

    It seems that the GUI App does not produce a zip archive that is able to be read by Repetier 
  • That is what I thought. Had also problems once I selected a other algorithm in 7-zip that made mac not unzip it. The format allows changing compression algorithms and then the extractor needs to support them as well.
Sign In or Register to comment.