Connection problem

Hi,

my system is Windows 10 and I have installed Repetier Host and Repetier Server last version. Everything worked fine until I have configured printer in Repetier Server. Now, when I switch On printer and PC RH can not connect to printer from Server and from Host to.


I found solution as follow:
- in Repetier Host window - Stop server
- communication is ok, RH working properly.
- in RH - Start server.
From this point everything working fine without problems.

Restarting server help in solving problem everytime.  Another solution is changing USB socket and port no. in Printer settings, everytime after PC reboot or switching.

Is any proper solution for my problem?

Mark

Comments

  • It is more a misunderstanding then a problem. If you configured the server for your printer it will autoconnect, which is why host can not connect to it directly. The idea behind the server is to use in host not the serial connection but the repetier-server connector. Then host would connect to server which is connected with printer and you have no problem. The big advantage is that you can even stop host and print will continue and of course you can monitor print in your local network with a smartphone to see if it is finished.
  • I have tested above. Server is connected but can do nothing with printer. Printer not responding. When I open Printer settings and close - I have all in red and server not working.

    Mark
  • Make sure in server prinetr configuration firmware is defined correctly. Setting it to repetier and having Marlin will not work. Also check baud rate.
  • I have Repetier firmware and all is set correctly, baud rate to. After server restarting all working fine. NO PROBLEMS. Problem is after switching devices ON , ONLY.
    I have to:

    stop server
    connect printer from Host, disconnect
    start server

    and from this point all is OK. I can work from RH or from RS local and remote PC.

    Mark
  • What printer and board do you have? For me server could always connect it self without needing host to connect in between. In fact that should normally not change anything. But I'm glad you know at least a way to solve it, but I'd like to know why this is required as it should not be that complicated.
  • I have modified Da Vinci 1.0A with Luc firmware.

    Mark
  • Does not sound special. Should work with server and no host interaction. Latest server version (0.90.6) has some more switches to change signals when connecting, also defaults are the same as in host.

    If it makes problems you could also try in server deactivate and activate to force a reconnect try after starting printer.
  • Thanks. Generally speaking server is ok. I like this software. Big Thank You for it.
    Regards
    Mark
Sign In or Register to comment.