Repetier will not connect

I am using PiBot electronics. I had my printer up and running perfectly for weeks. On Sunday my laptop was having serious issues. When I would try to open Pibot 1.08 it would give me a blue screen of death and crash the system. I dont know what version of Repetier this was since as soon as I try to open the software it crashes immediately, but it looked the same as the Repetier screens.  I had the same issue trying to use ReplicatorG.

After wiping my laptop and a fresh install I went to the Pibot homepage, all their software is taken down. I still have 2 versions that I had downloaded previously.There is a hardware driver installation program also that installs PL-2303 USB to serial setup.

I have tried several versions of Repetier to connect to the printer. I get the green connected button but nothing works. When I check the printer info it says unknown and no info.

I am frustrated and lost and dont know what to do to trouble shoot this. I never had this problem the last time I installed the software, it was very easy and I had everything set up and running perfectly, now I have nothing.



  • If connect goes green there is a connection to the board. If baudrate is wrong you will not get any communication running. For this check the log, e.g. if you see a "start" message in the log when the firmware resets. If you do you know the baudrate is correct.

    Since it happened while you tried to connect (blue screen) it also might be that a component on the board went defect. Had this myself once and after that I could talk with the board usb converter, but the converter did not talk with the avr chip any more. All I could was receiving messages, but sending wa simpossible. As a good test for hardware problems upload your firmware again over usb. If it works the hardware is ok. 
  • I found an old backup I had the previous version,1.06, of PiBot saved on and loaded it, got the motors to move again but the hot ends will not heat. The thermistor shows proper temperature and it says "Heating Extruder" but it doesnt. I will have to check wiring when I get home, I ran out of time.

    I am not sure what version of Repetier is used with this version of PiBot, I know it is pre-1.04. It seems odd that it will work but when loading 1.04 Repetier (or any earlier version either)it will not function. Is there some kind of driver that I am missing for it to function?
  • Repetier-Host uses the standard serial communication functions of windows and has no drive ron it's own. So if uploading firmware works, drivers are ok.

    I know the PiBot guys had a modified version of Repetier-Host (older version base), but I don't think there were significant changes. Only perhaps default matching their board. But that uses repetier-firmware in some version, so there should be no problem at all once you have the right baud rate selected.
  • Well I got my printer to "Work".

    My MB can regulate the heat of 3 extruders. Say I wanted to turn them all on at the same time, but not list it as more than one extruder when I slice, can I use the "custom G-Code" tab to add a command to turn all 3 on and monitor/regulate?
  • In printer settings->Extruders you have to tell the host how many extruders you have. Then you see them also in slicing tabs.
Sign In or Register to comment.