Repetier Serever and Duet wifi

Hi,i have three 3d printer delta with duet wifi board.With usb no isue,but if i used TCP/IP Telnet back port 23,in print,printer randomly stooped for 1/2 sec and go on.All 3 printer,same problem.


  • The problem is that this does not copy the file to the printer, so any problem with wifi will be able to stop communication and in extreme cases even break it completely. This sounds like communication over wifi is blocked for some reasons, maybe dhcp lease renewal, connection issues, or what else can make wifi pause for a short while. Better is to have a small computer with wifi running the server close to printers and connect with usb. That way wifi issues can not break a print since nothing interrupts the server->printer communication.
  • Thanks,but i have the printer in 3 different location,and the usb connection is not quite good for me.Is any way to upload the gcode to duet wifi sd card? Or setting up the repetier server to use duet wifi sd card? In this way the printer read the gcode from buit in sd card and the server use the telnet only for read the status,control printer,eta,temp etc....
  • Running from sd card will remove most advantages of the server, so that option is currently not implemented. And the duet solution only works on these boards and not in general. General solution would be upload gcode using gcode which is generally a pain regarding speed, so the duet solution is at least great with that respect. You can of course manually upload to duet interface and start and monitor temperatures with server. But we do not see progress or that it is printing etc. That is as I said what you loose then.

    If wifi is in general working good you could maybe check if your wifi router has a log that shows reasons at the time of the interrupt. At least if it is lease renewal you could increase that in most routers. If it comes from other networks a different wifi channel might help here. I mean it i snot a big problem apparently as connection does not break, just something that prevents packets being received for a short period. Once you know why you can solve it.

    I do not know reprapfirmware that good but maybe you can also increase the input buffer size. I assume you have ping pong disabled in server. With a bigger buffer you reduce the pauses as well. Just let server know about the bigger buffer size so it also gets used.
  • edited September 2018
    Any Duet have the same mac-address. You have to modify the mac-address on any boad with different one.

    es. M540 P0xBE:0xEF:0xDE:0xAD:0xFE:0xED ; MAC Address

Sign In or Register to comment.