No filament feed

Repetier Firmware: V.
Repetier Host: V 2.1.3
Printer: Da Vinci 1.0
Slicer: Slicer3
OS: Windows-7

The installation went well and everything seems to be working normally ... except .... when I run a print, no filament comes out of the extruder.

- filament extrudes normally if I use the manual control.

- after slicing, in Print preview under "Printing Statistics" it shows filament needed as 0mm

- when I look at the gcode with an editor (Wordpad) there are no entries of the form G1 .... Exx .... there are no Exx arguments at all.

This seems such a blatant omission that I'm sure I'm missing something obvious, some parameter not configured perhaps, but I can't see what it is.

I'm hoping that someone with more experience of Repetier can see what's going on.


  • Sounds like you selected mach3 as firmware flavour which uses A not E for extrusion. Check you gcode if it contains E moves or not.
  • Well, as I said above (in my stumbling fashion), the gcode doesn't contain any E-moves. I didn't (but will) check for A-moves - didn't realise that possibility - nonetheless, the "Printing Statistics" show 0mm filament needed which suggests the slicer isn't actually using any filament.
  • Further to this:

    - There are no A-moves and no E-moves in the gcode.
    - The firmware is version 0.92.10M

    Don't know if that's enough to identify the firmware flavour or not. I wouldn't, wittingly, have chosen a Mach3 flavour except on a best-of-a-bad-bunch basis since I have no intention of using Mach3. Still, if that were the "default" version, it could be what I've got.
  • Even further to this, I found the problem:

    First I tried the Cura slicer in place of Slic3r and it gave me sensible filament requirements in "Printing Statistics" so it appeared that the problem was Slic3r related. After much digging, poking and drilling-down in Slic3r I finally found a parameter "G-Code Flavour" which is set to "No Extrusion" by default and needed to be set to "Repetier" (in this instance).

    (Since, with this default, Slic3r wouldn't actually do anything useful in any situation, I'm surprised that it doesn't draw attention to this parameter and recommend that it be set to something workable on initial installation.)
Sign In or Register to comment.