RPi - Touch UI not loading, at CLI


Installed from SD card latest image onto Pi 3B+ with 7" touchscreen and was all working great.
I then did a full package update (apt-get upgrade)

WebUI still works fine but touchscreen is at CLI
How do I set the UI to auto load / where are the logs I need to check whats gone wrong ?


  • From which image did you do the upgrade? The guess would be that the upgrade destroyed a important part. In .bashrc in home directory at the end you see the command xinit .... that starts the graphic system with chrome. Maybe the update changed the file? Try executing that line manually and see if you get any messages. Also /var/lib/syslog might contain some hints if the upgrade just causes a problem that results in not starting.
  • It was the latest image contained here :- https://www.repetier-server.com/download-images/

    The .bashrc file does contain the xinit element at the end to see if it needs to start the GUI with Chrome.

    syslog does not indicate any errors I can see - anything else to check ?
  • Only manually starting it in commandline to see if you get a message with some hints. X server might have it‘s own log but being on vacation i can not check that.
  • good idea, will try that and report back; but most importantly enjoy your holiday !
  • So I got a keyboard, plugged it in and logged in locally - the UI fired up.

    Could it be when I changed the default password I broke some auto login ?
  • Ok sounds better. The trick is that we enbled autologin for  so the command runs at the end of that. So it seems only autologin is not working. Try running
    sudo rpiconfig
    i think it is named. There is menu entry to enable commandline start screen with autologin, maybe you need to redo because of the password change.
  • edited July 2018
    Ah cool, once this print finishes (12 hours) I will give it a shot.

    BTW so far I'm loving repetier and its been worth every penny - keep up the great work !

  • That fixed it using the config program :)
Sign In or Register to comment.