compile problems

Hi, I am trying to compile Repetier, but keep getting this error,
Repetier.h no such file or directory.
I have tried this with several boards and two different computers, with the same error.
Even tried it with Marlin, it's just got me beat.
Any help would be highly appreciated.


  • The file should be in the same directory the Repetier.ino file that you try to compile is in. If mot, please download again the complete firmware and you should have it.
  • edited July 2018
    Ok thanks, Arduino ID put the ino file in a seperate folder, I ended up having to put all the .h files in that folder, but still got the following errors. 
    What am I doing wrong here.

    Arduino: 1.6.13 (Windows 7), Board: "Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"

    C:\Users\user\AppData\Local\Temp\ccg9oO90.ltrans0.ltrans.o: In function `main':

    ccg9oO90.ltrans0.o:(.text.startup+0xe0): undefined reference to `Printer::setup()'

    ccg9oO90.ltrans0.o:(.text.startup+0xe8): undefined reference to `Commands::commandLoop()'

    collect2.exe: error: ld returned 1 exit status

    exit status 1
    Error compiling for board Arduino/Genuino Mega or Mega 2560.

    This report would have more information with
    "Show verbose output during compilation"
    option enabled in File -> Preferences.

     Did this but have no idea what it is about.
  • Try upgrading to latest Arduino IDE. Never seen the ide move a file on it‘s own, so strange for me. I also do not see where this ltrans file should come from. It is none of our files and it is missing important files from our firmware which is why you get the errors. You are doing something that should be simple wrong. You should just
    1. Run config tool
    2. Download zip and unzip
    3. Open arduino ide and select Repetier.ino in repetier subfolder.
    4. Set your port and motherboard.
    5. Hit compile

    You do one of the steps differently also i do not see which one.
  • I have gone through this exactly as you say.
    I down loaded Arduino Ide v 1.85.
    Ran the config tool down loaded the zip.
    Ports set
    hit compile and arduino puts the Ino file in a seperate folder, and tells me it can't find repetier .h
    And we go though the same process as above.
    Got me beat
    It sounds as though something is missing in the Ino file, just my guess.
     here is the last section of it.

    void setup()

    void loop()
  • No, but you see the 2 commands that were missing when linking. This only works if all files are in one folder. Please check arduino settings - it has never moved the ino file in a new folder. It would only try this if you have renamed repetier folder because the folder must have the same name as the ino file. But my actions do not contain a rename so it should work.
  • edited July 2018
    Thanks, well that cured part of it, when I unzipped the download into a folder, I spelt the name wrong, that has stopped it from putting the Ino file in a separate folder.
    But it is still telling me that files are missing , when they are not. It is looking for SdFatConfig.h
    I might need to get a hair transplant after all this.
    Ok I have just tried this on two different computers, a Win 7 pro and Win 10, both with same result.
  • Have you upgraded to 1.8.x as i told you? Latest firmware requires this, because sd library is included in a subdirectory and older ides do not check them.
  • edited July 2018
    Yes I have 1.8.5 on both computers. and the SD library is there.
    May I ask a question here.
    I have not as far as I know enabled the SD, I do not use it, so why is it looking for it ?
  • The way i upload to my board
    Do not start arduino ide
    unzip the repetier firmwar to desktop
    open the created repetier folder (now on the desktop)
    double click the .ino file (this should automatically open arduino)
    in arduino ide click the 'tick' to compile

    this way everything 'should' be in the correct folder.

  • MartinH, 
    thanks for the reply, what you have said is exactly how I do it, nothing different at all, so the problem is not with the method of operation. I am not saying it is a problem with Repetier, but it must have something to do with a setting somewhere,BUT, where. Most likely in configuration file, I just don't know where to look.
  • Please check the repetier folder. It should contain a subfolder where the sd library we use is stored. This gets preferred to the official one, which is good, because we need. Modified version.
  • No there are no subfolders there
  • I have to check that next week. You can use the version from github which should contain the subfolders.
  • OK, downloaded from github, there is no subfolder ther either. but it is now telling me that icstream is missing when it's not, just about to give up on this
  • On github i see the src/SdFat library in Repetier folder.
     No idea why you can not see it. See here
  • You had me looking for a subfolder . I don't see src/SdFat, just SdFat.h I assume it;s the same as it is now looking for iostream
  • @ernihatt ;
    can you post a pic of what you see
  • This is the current error I am receiving from Arduino.
    What I don't understand is why, when the file is there.
    I am afraid I am not smart enough where programming is concerned.

    Arduino: 1.8.5 (Windows 7), Board: "Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"

    In file included from sketch\Repetier.h:626:0,

                     from C:\Users\user\Desktop\Repetier\Repetier.ino:184:

    sketch\gcode.h:22:20: fatal error: iostream: No such file or directory

     #include <iostream>


    compilation terminated.

    exit status 1
    Error compiling for board Arduino/Genuino Mega or Mega 2560.

    I M not sure this is to do with the configuration file after all, but I could be wrong, I downloaded a fresh unaltered configuration file, and I am still getting the same errors.
    I really need to get this working, so where else could the problem arise from.
  • Quote:
    "I M not sure this is to do with the configuration file after all, but I could be wrong, I downloaded a fresh unaltered configuration file, and I am still getting the same errors."

    you have to download complete firmware , not only configuration file.

  • I had already setup and downloaded the full firmware, but was getting these errors, which I believed was some setting that I had done in the configuration .h file, so to I just down loaded an unaltered one which I pasted into the repetier folder, deleting the original. but I am getting the same error. this should work. but to make sure I will go through and do it all again, without making any changes to the configuration file, and see what the result is.
  • Hey don't ask me what I did right this time, but I got it to compile, must be smarter than I thought. o:)
    Thanks Guys for you help and patience.
  • I am having problems setting endstops, and the X axis is only moving in one direction, but if I hold  in the endstop it will move but only once.
    Can anyone please put me right here

    Here is the endstop settings, the Z is fine.
    the X axis stopend is on the right, the y is at the front
    define ENDSTOP_PULLUP_X_MIN true
    #define ENDSTOP_X_MIN_INVERTING true
    #define MIN_HARDWARE_ENDSTOP_X true
    #define ENDSTOP_PULLUP_Y_MIN true
    #define ENDSTOP_Y_MIN_INVERTING true
    #define MIN_HARDWARE_ENDSTOP_Y true
    #define ENDSTOP_PULLUP_Z_MIN true
    #define ENDSTOP_Z_MIN_INVERTING true
    #define MIN_HARDWARE_ENDSTOP_Z true
    #define ENDSTOP_PULLUP_X_MAX true
    #define ENDSTOP_X_MAX_INVERTING false
    #define MAX_HARDWARE_ENDSTOP_X false
    #define ENDSTOP_PULLUP_Y_MAX true
    #define ENDSTOP_Y_MAX_INVERTING false
    #define MAX_HARDWARE_ENDSTOP_Y false
    #define ENDSTOP_PULLUP_Z_MAX true
    #define ENDSTOP_Z_MAX_INVERTING false
    #define MAX_HARDWARE_ENDSTOP_Z false
    #define max_software_endstop_r true

    #define min_software_endstop_x false
    #define min_software_endstop_y false
    #define min_software_endstop_z false
    #define max_software_endstop_x true
    #define max_software_endstop_y true
    #define max_software_endstop_z true
    #define ENDSTOP_X_BACK_MOVE 2
    #define ENDSTOP_Y_BACK_MOVE 2
    #define ENDSTOP_Z_BACK_MOVE 2
  • Check using M119 to see if signals are good. H for triggered and L for not triggered. If it is always theopposite checke inverting. If it is no mechanical end stop you might need to disable the pullup.
  • Thanks, got both the X and Z axis stopends working Ok, but The Y is giving some trouble, I am trying to get it to trigger at the front of the printer, If I connect it to the min socket it move towards the back only if I press the endstop, put it to the Max side then I get no movement.
    Also I get a shudder when it starts a move, how can I cure this.
  • If you plug the Y endstop into the Y max socket you need to set 

    #define MIN_HARDWARE_ENDSTOP_Y false
    #define MAX_HARDWARE_ENDSTOP_Y true
    #define Y_HOME_DIR 1
  • Thank you very much, was not what I actually needed but it did lead me in the right direction to fix it.
    Now, fingers crossed, I have one slight problem left.
    There is a distinct shudder at the start of a movement,on the X and Y axis, but when homing it is very smooth.
    I tried fiddling with the jerk but that made little difference if any.
    Any ideas Guys.
  • When motors get first on it positions at what driver have stored as substep. When off they are where magnets hold best. So this difference is done as fast as possible. So if you only speak about that ignore it, it is normal.
  • Thank you so much, your help has been highly appreciated.
Sign In or Register to comment.