Prusa i3 MK3 heatbed not showing temp

Hello guys.  I looked at the forum here about issues with the MK3 heatbed.  I know what the issue is by reading through the forum but I did not find any information about how to correct it.  The heatbed is just saying undefined.


  • What is the M105 response in console. You need to enable ACK to see it.
  • And did you upgrade to 0.90.1 already? We at least tried to fix the prusa problem, but having no prusa we could not test.
  • I'm having the same problem across my three 3D printers, worked fine with an earlier version of repetier server, now the heated bed shows undefined in the setting area, same as OP, but the heated bed temperature is being reported normally in response to M105 and heats correctly to the set point. Using repetier firmware 0.92 for all three printers.
    e.g. M105 21:22:41.637: T:11.63 /0 B:13.18 /0 B@:0 @:0
  • @chrisgrul Can you open debug console in browser to see for error messages and also make a screenshot. I'm wondering about the problem as I have it running with latest version and our firmware. You might also try clearing cache in browser and reload in case it was using a old javascript as the format changed in 0.90 for bed reports.

  • I'm having the same problem with the 0.90.1 update.  It seems to have lost my configuration for the heated bed.  Doesn't show up in the UI as available for setting temp, etc.  I looked at the XML config file and the heated bed section is mostly blank. M105 returns:

    16:20:16.880: ok T:26.03 /0.00 B:27.41 /0.00 @:0 B@:0

    This is the armel version running on a pcduino2 board.  It was working fine until I upgraded to 0.90.1 and I haven't changed firmware or anything.  I'm going to downgrade back to 0.90.0 and redefine the heated bed since others are having issues with prints stopping in the middle.  I have a 5 hour print I'm about to start.

    This is with an I3 variant running Marlin 1.1-bugfix from several months ago.

  • I downgraded back to 0.90.0 and re-added the heated bed configuration.  It now shows up in the upper right area of the web UI, and I can select one of my presets, but it's not showing me that the bed is on or the temperature.  The bed is heating up though, so it did actually turn it on.  Seems my webcam configuration also got wiped out, but I'll start a new thread for that.
  • Bed and webcams now can have multiple entries, which is causing the trouble and that is also one update in 0.90.1 to 0.90.0 to fix it in touchscreen display. Other handling had stayed the same. Should upgrade to new config automatically, but seems not to work for everybody which is why you loosed the bed config i guess.
  • After I downgraded to 0.90.0 and re-added my heated bed as described above, I then re-installed 0.90.1 and the heated bed configuration seems to have remained and is working properly showing the temperature and the status of the bed.  Could it possibly be because I had gone through the warmup/cooldown calibration previously with 0.86.x that caused it to wipe out the config?  After I re-added the bed earlier today, I did not do the calibration wizard.
  • Should not be the problem. But i need to find why it happens. Anyhow redefining lost config parts seem to work, so you can continue.
  • I am having a similar issue.  Has this been solved? I am on a Raspberry Pi with no screen, connected to Anycubic i3 Mega Ultrabase.  Image file name: "Repetier-Server-Image_0_90_0_v9.img"  I could send a command with the Heated Bed GUI but it would not display a temperature.  The screen on the printer would show it is heated.  Please see link for screen grab: ; I started a print since temps were good. 

    It so happened this was my first print with Repetier-Server and it failed, not sure why, but that is not the issue here. After I canceled the print, I was able to click "Off" for the hot end and bed.  The display on the printer indicated they were cooling down.  I clicked the "0" and entered 60 on the bed control.  Actually I clicked the left side of the displayed zero and entered "60" which displayed "600", I pressed Del, but the zero on the right would not go away, so I pressed backspace to get rid of the middle zero and hit enter.  Bed temp went back to heating and controlled to target.  I captured the message for debug:
    1:02:38.974: N458407 M105
    1:02:38.978: ok T:76.6 /0.0 B:60.8 /60.0 @:0 B@:127
    After this I tried to enter "0" on the heated bed section of the control tab.  Heater stayed on.  I clicked on the bed icon on the top right and clicked "Off" and the bed turned off and started to cool down.  Throughout the whole process, the Heated Bed display nor Heated Bed graph never showed a temperature or a setpoint.  At least I had good adhesion. 

  • Please upgrade to 0.90.1 where i fixed some gui issues with heated bed. Will check when i‘m back if that was fixed in that version as well.
Sign In or Register to comment.