Slic3r PE doesn't work in Repetier


I’ve installed the last version of Repetier Host (2.1.2), I’m triying to slice a model with Slic3r Prusa Edition but I am getting few troubles:

When I try to slice with Sli3r PE, I can’t choose any print seetings in Repetier, they doesn’t appear in the tabs. ¿Any idea why is this happening?

If I press “Configuration” it opens Slic3r PE v 1.40.0 –beta, but I want to use Slic3er PE v 1.40.0. (the one I have installed) Is Repetier installing beta version? How can I redirect it to v 1.40.0?

I'm newbie using Repetier Host so probably this is easy to solve but I have no idea how to do it. I appreciate if someone could help me.



  • Hi,

    I have the same problem.
    When I try to slice with Sli3r PE, I can’t choose any print seetings in Repetier, they doesn’t appear in the tabs.

    I’ve installed the last version of Repetier Host (2.1.2) with Slic3rPE  v1.40.1-rc+win64

  • Select the manager and not configuration. Then you can set the executeable (e.g. newer version) and also the data storage directory. Remember that slic3rPE does use a different directory then Slic3r as they are drifting apart a bit.

    If there are no configs make sure to use the right directory and check log for error messages. If config dir is correct and has entries, please send us the directory for testing if something crashes for unknown reasons.
  • I've used the directory C:\Program Files\Prusa3D\Slic3rPE\slic3r-console.exe in the executable (the directory where the new version of Sli3rPE is installed) but it's not working..the seetings don't appear in the tabs. 

    It seems Repetier is slicing but I have no idea which settings is taking for that.
  • What did you set the data directory to?
    Slic3rPE default is $HOME/AppData/Roaming/SlicerPE 
    I think. See if the subfolders contain files. Start configuration to see the native gui and see if that shows configurations.
  • Yes, I set $HOME/AppData/Roaming/SlicerPE as a data directory.

    The subfolders : filament, print and printer don't have any file.
    If I start configuration the native gui shows the configurations

  • I guess I've solved it.
    I replaced the empty folders in the data directory with the ones I download from Prusa and now it's working. <span>:smile:</span>
  • I wonder that slic3rPE does not create default configs once you run configuration. I will test this. But empty directory explains why it does not show any configs. Guess you saw some defaults then in the slicer gui.
  • Right, the defaults in the slicer gui are not shown in the directory....the root problem is unsolved.
  • I also have this problem. I have also noticed a problem where if I import a GCode file into Repetier Host (GCode created in Slic3rPE) that it will only display the first ~10 layers. I can use single layer view and move through them as normal, but still those ~10 layers are all that show up. There don't appear to be any issues with the GCode files as they print properly.
  • Yes, that is a known bug only showing first layers. It happens if slic3r generates relative extruder coordinates. Have fixed it already for next update.
  • I have the same problem running Repetier Host Mac 1.1.0 and Slic3r PE 1.41.0+. The sclicer pane in Repetier Host doesn't show any settings, when I click on "Slice with Slic3r" I get an error saying "Slicing exited with error!" but I can start the standalone Slic3r PE by clicking on "Configure".
  • The mac version was never tested or meant to work with the mac version. Especially unknown infill patterns come as a source of problems in my mind in that combination.
Sign In or Register to comment.