Connection Lost?

Hey guys,

i have a Anycubic i3 Mega and the Repetier Server run on a Raspberry Pi 3.
The Server worked perfect. 
Since two or three weeks i got a big problem.
The first layer will be printed perfect. In the second layer the printer drive to the right corner and make a crash.
I tried a new USB cable and to reduce the Baudrate to 115200. Nothing happend.
The error occurs not every time but in two of three cases. 
I have got more then 11 GB free space on the sd card.

Can someone help me?


  • Check /var/log/syslog at the time of disconnect. If you see a usb disconnect there it is linux who disconnectes usb bus to reduce power consumption. Make sure the Anycubic powers the printer board on it's own and get a better power supply. Disable starting x server with chromium to reduce power usage of pi.
  • Update:
    I disabled x server and bought a new Power Supply (5V/3A).
    Nothing works. Some error.
    I try to install Repetier on a Raspberry Zero W now. Hope that works better.
    Pity that the Repetier works not on my Raspberry 3.
  • Did you check  /var/log/syslog to see if that is the problem?
  • Yes. In the syslog are entries with usb disconnect and so on. Tomorrow i will try the original anycubic firmware. I've changed the firmware to marlin 1.1.1 (github search anycubic i3 mega marlin). The movements with marlin are smoother as the prints with the original firmware. I printed a 12h job without error from sd card, so i think it's not a printer probelm. I think it's a connection issue but i don't know a solution
  • Yes, if you have the disconnect messages in syslog it i slinux doing this, so out of our scope. It seems the raspberry is very prone of the usb problem. For man yuses it works find but some have problems with it. What you also can try is adding a powered usb hub between pi and printer. With some luck this helps.
  • New Update:
    Successfull 10h job. I had edit the script like you at your homepage. 
    My script was a litte bit different then yours.
    So i comment all of the rest at the script and this was my failure. 
    Uncomment chmod ...... tty and everything is fine.

    I make Screenshot´s if i am at home so you can put the before after pictures in your guide at the homepage.

  • Please also post page url you mean. Not sure what you mean at the moment.
  • edited July 2018

    I edit the code like the "no display guide".
    Screenshot of the wrong script and no display script at the bottom-> that will no work

    Then i edit the script like that -> that will work.

    I hope this will work on the other rapsberry too  :)

  • The new way is now a different also the result is the same. Have changed the documentation.

    No Display

    If you have no screen on your pi, you can disable the start of x server and chrome. This reduces CPU and RAM usage. Especially if you have
    sometimes printer disconnects from low power this might help reduce or even remove the problem.

    Change in windows

    On windows you see only the /boot directory. Edit the file “repetier-image-setup.txt” to disable GUI.

    Linux solution

    Log in and edit /boot/repetier-image-setup.txt

    nano /boot/repetier-image-setup.txt

    Edit the disable GUI option to our like and safe using Ctrl+X.
    On next reboot the x server will not start.

  • Today the error occured again :(
  • So it is only an improvement. I have seen posts saying reduicng usb to version 1.1 also helps, but do not really like that idea. Pi already has only USB 2.0 for all causing some limits as it uses wlan also over usb.

    Did you already tried the powered hub in between?
  • I think it is a problem with the software. Today I tried a print from Repetier and from SD Card and both were stopped at the second layer. I start now a print with the original firmware, we will look what happen.
  • Now all works. I install a raspberry pi zero with raspbian. I install the repetier package and all works perfect.
  • So between which firmwares did you switch and what was the one causing the connection lost?
Sign In or Register to comment.