Repetier says connected but bed and nozzle do not heat up

I had an older version of Repetier, all was working well, then I agreed to update and the new repetier crashes my computer all the time, so I reverted to the old version, but then, new problem: I connect, it says connected, but the heater do not kick off and the reported temperatures are zero. It is normally at least 22degrees for the bed, the room temperature...

After a while, I get a "Communication timeout - reset send buffer block" but the "connected" icon stays on. I'm connected by USB through COM3, has always worked great for the past 2 years and printed multiple models using repetier, never a problem. It even stayed connected when I reopened the computer, which I liked about the older version.

I tried all sorts of things, including connecting through "repetier server" whose interface I admittedly do not really understand, but it seem to say it is "active" (and yes, I made it inactive while trying to connect directly from repetier host), yet it also doesn't work. It does say it connects to the server, but then times out and I cannot see my heated bed (I also cannot move anything, x, y z, etc..). See screenshot:

I was able to confirm that my machine (A makegear m2) is not at fault because:
1- i can connect AND print using an older version of cura (v.15) which then accepted to connect through com ports (the new version is network only)
2- I'm also able to connect using the manuf's setup utility

Also, it does not seem to be the computer's USB ports, as I tested it on 2 different computers with the same result (and again, i can connect with other software)

My best hypothesis: I'm missing one step somewhere which, for some reason, when I first installed repetier 2 years ago, I had right, but am now forgetting or misunderstanding... But what is it? no clue, i tried many things. I'm on COM3, it reports connected but isn't really, etc...

Any ideas?


  • With the server connection, part of the confusion is that you can connect to the server also if the printe ris not connected/online. So if host says Repetier-Server successfully connected it means it is now talking with the server. Then it comes to the printer connection is seems to not connect correctly. In server it is important to select the right firmware and the right baud rate. Selecting Repetier-Firmware on Marlin will only give errors like this. Sam eon host if you select binary protocol on marlin firmware.

    Be din host appears only after temp. reports a bed present and that only happens after successfull connection.
Sign In or Register to comment.