Unable to close message box (AppImage version 2.0.5)

Hello I'm having very small issue - a message box will not close and freezes the entire repetier host app. The message is shown when I'm trying to load objects bigger than print bed.
"Printer Bed Full" - "Too many objects on printer bed for automatic packing...."
After this message is shown I repetier seems freezed and only thing I can do is to kill the app process.
Other than this is all fine :)


  • This only happens if your bed already contains an object. Have tested it on windows and it worked. Will test it when I make the linux update if linux has the problem as well.
  • Yes I have not tested other error message boxes (as I dont have any other errors :) but when I try to put two or three objects and they are bigger then bed size, I have to scale them down, and then bam the message pops up which I can not close. Will be happy to help/assist you solving this.
  • Some more details, I'm on ArchLinux with latest updates, I have also tried to use the unpacked AppImage contents, and use the system installed mono version but it happens again. It seems the dialog can not be disposed properly and return to the main loop is not possible further.
  • I have tested it with ubuntu 16.04 and loading a big model only causes the error if bed was not empty. But I could simply hit ok and it disappeared just like with windows.

    What is with other error boxes like trying to connect with printer when printer is not connected. All use the same MessageBox form which comes form the OS in windows. In linux there is some workaround in mono to get them I think but should work the same for all boxes. So does that also not work?
  • I'm ok if there is error message because of the model is bigger than bed size. But problem is I can not close it. Clicking the 'ok' button does nothing. Can you elaborate more on the 'linux workaround for mono'. I was googling for some fix but found nothing so far. 
    On the other side - I've tested connecting to the printer when printer is turned off and nothing happens. No message box is shown on screen but inside the terminal window there is an exception thrown correctly ?

    Opening serial failed on second try:System.IO.IOException: No such file or directory
     at System.IO.Ports.SerialPortStream.ThrowIOException () [0x0000f] in <2b0d86369d72459baed0cee98a8e578a>:0  
     at System.IO.Ports.SerialPortStream..ctor (System.String portName, System.Int32 baudRate, System.Int32 dataBits, System.IO.Ports.Parity parity, System.IO.
    Ports.StopBits stopBits, System.Boolean dtrEnable, System.Boolean rtsEnable, System.IO.Ports.Handshake handshake, System.Int32 readTimeout, System.Int32 wri
    teTimeout, System.Int32 readBufferSize, System.Int32 writeBufferSize) [0x0001b] in <2b0d86369d72459baed0cee98a8e578a>:0  
     at (wrapper remoting-invoke-with-check) System.IO.Ports.SerialPortStream:.ctor (string,int,int,System.IO.Ports.Parity,System.IO.Ports.StopBits,bool,bool,S
     at System.IO.Ports.SerialPort.Open () [0x0006f] in <2b0d86369d72459baed0cee98a8e578a>:0  
     at RepetierHost.model.ProtectedSerialPort.Open () [0x00037] in <e2caed22f11747c098ebda9551e8adde>:0  
     at (wrapper remoting-invoke-with-check) RepetierHost.model.ProtectedSerialPort:Open ()
     at RepetierHost.connector.SerialConnector.Connect (System.Boolean failSilent) [0x00220] in <e2caed22f11747c098ebda9551e8adde>:0 
  • Ok, you are right. Another thing mono does different. So connecting will not get you the dialog, If you go to preferences->informer and send a test message without group you also get such a messagebox. You should be able to close it with mouse/space or return.

    Did you also test space and return with the big size message?

    As I said it is a buildin function we do not write just use, so implementation is inside mono. What I do not anderstand is that I can close it while you can't. Can you therefor exactly say what you do and when it appears. As said I only get it on second load if it does not fit, but can close it, so maybe you do it differently and that makes a difference somehow.
  • I think is not problem with repetier-host. It suddenly started working normally. Possible just a mono integration issue. I'm on KDE but also installed GNOME packages and it started working fine.
    Thanks for your time.
Sign In or Register to comment.