Homing, Autoleveling and Manual Control

I have a printer that I have now fitted with Auto leveling :-)  When I home the printer it first goes to x and y =0 then it moves to the centre of the bed before setting the z height.  All this works fine.

If I then try and manually control the printer I then have an issue where I can only move towards the positive.  Clearly because repetier host thinks that I am at X=0, Y=0 so it rightly does not want me to try and go negative.  In reality I'm at X=100ish and Y=100ish and repetier host will allow me to move 200 from my current point forward and right...ouch.

Am I missing a setting somewhere that tells repetier host that my printers homing position is in the centre not at the lower left?  I have looked but have not yet found?  Otherwise is there anything I can do about this?  I'm concerned when I print it may cause an issue.


  • What type of printer do you have , delta? cartasian? core xy ?

    normally a delta is 0,0 in the centre, the others are 0,0 at front left of the bed.
    In RH/printer settings/printer shape, you can set the bed size and home postion.

  • In host printer shape you also need to define homing position after G28, then host allows you to move correctly.
Sign In or Register to comment.