USB Device malfunctioned

edited February 2018 in Repetier-Host
So after fixing a few issues with the printer (K280), I decided to try to print a few things. But alas, when I tried to connect the USB to the computer, this happened

So I looked around and tried to find a few solutions but nothing came up. 

I looked at my device manager and tried to update my driver but that wouldn't help. 

One thing I noticed though. Before I tried to print today, my computer restarted and ran a quick update. Before this update, I could connect to the printer without problems. My luck. 

Any ideas on how to do this? I temporialiy have my printer running with the SD Card but a) it is a pain and b) for some reason it thinks the Z Height is much lower... 


  • Only solution I can think of is uninstalling and then reinstall. From your description I guess that the windows update did something.

    Alternative solution is to have a mini computer like the raspberry pi and run repetier-server on it. Since it is then a linux system it will not be affected by windows driver problems. And host can connect to pi using the server connector.
Sign In or Register to comment.