Decoupling Error

I have a K280 printer and I printed out two prints when I ran into a decoupling error. I checked to see if there were any volts going through the place where the wire connected to the board (there were about 24v) and checked if the temp sensor was working; it did.

I got a hair dryer and blew hot air on the temp sensor as I told the heater to heat to 200C. So I basically tricked it to believe the heater was heating up, so it continued to heat itself instead of giving me an error ("dec" on the LED screen).. This should indicate that there isn’t anything physically wrong?

I am dumbfounded as to why. I did buy a spare one but I don’t know why it’s giving me this error and wanted to see if it could have anything to do with the firmware?

Comments

  • First you should analyse log especially the first error where firmware explains what triggered it.

    It can just be a bad calibration of decoupling test parameter so you trigger it just because some part did not correct fast enough. Especially if it looks like it is normally working.

    There is also the defect error which can happen also if some wires are broken or shorten but only randomly. But then the error is not decoupled but defect.
  • edited January 28
    The log basically says the heater didn't heat up fast enough in a x amount of seconds. Which is true because usually, when the printer was working, the heater heated up pretty quickly (40 C in < 5-6 seconds) whereas now, the heater just stays at 25 C when the heater LED is flashing. 


  • So it is hardware defect if it does not rise any more and worked before. Maybe just a broken wire. To be sure you can measure voltage at output before error happens if it is 12V. Then you know board wants to deliver and you need to search on the other side of the hardware.
  • edited January 29
    So if I understand you correctly, measure the voltage where the wires connect to the board and if it is 12V before I tell it to heat up, then it would be a heater problem, not the board? 
  • No you need to tell to heat up. But you need also to measure before decoupling triggers and disables output. Then it will be 0V anyway like before enabling heater. So you have 13 seconds to measure.
Sign In or Register to comment.