first start notification says the print will end at the time it started

I just started a print at 6:18:05 PM.  At 6:18:06 PM I get a notification "print for printer default started.  The print will finish around 6:18:06 PM.   Unless I have one of those new supersonic 3D printers that just isn't right.  Any idea how I can rectify this aside from just disabling the print start notification?

Android S8+ running Android 7.0 and Repetier-Informer v. 1.0.0

Thanks much,.

Dave

Comments

  • Which software and version was the sender? Host or server? What is the time prediction for your print in it? Maybe there is something in the code confusing time computation like homing at the end of print, which at least was a problem.
  • The sender was the server.  Server is 0.86.2 running on a pi 3. The time prediction was about 2 hours.  it has happened quite a few times.  Actually happened again about 3 hours ago.  I'll take a screen shot of it and send it tomorrow for you to see.
  • edited January 23
    Sorry for the delay.  As you can see it generally doesn't work.  I see one or two where it did report the proper time.  At first i thought it may be tied to the default printer profile but I found a few where the Maker Select profile did it as well.  




  • I cannot edit this any longer but these are from the host.  The server does the same thing but just in GMT instead.  I need to see if I can find a way to have it show current system time zone rather than GMT (I hate math) <span>:smiley:</span>

    Dave
  • Can you post a gcode where it did not work so I can test if it is gcode related somehow.

    Do you print directly or do you upload a model and then select it for printing? Maybe that is the difference and message gets send before time computation is finished. WOudl at least explain the error and why it does not happen to me as I always first upload to models and then print the model so computation is already done before starting the print.
  • edited January 23
    I slice w/ the cura slicer w/in repetier-host which gives a time and then print so I believe it sends gcode first.  I get the notification as the print starts, not as it's sent.  I'll have to get you a gcode in the AM.
    Dave
  • When you do it over host and hit print it is not stored as model and gets deleted after print is finished. That is the case where I think it might send message before finishing time computation. But it is also the fact that the host time estimate is not relevant as server will use it's own estimate, so gcode might still be the reason so sending me one is still good for testing.
  • I disabled all host push notifications and just ran a test print and that came to me properly.  I wonder if the host initiated notifications were the issue.  With that said I'll monitor this and report back.  Can you tell me if there is a way for the server push notification to use system time rather than GMT? 

    Thanks
    Dave
  • If you print using server the server will always push the messages.
    The timezone is the timezone of the computer the server runs on. If you use our pi image that would be GMT. YOu need to change the timezone to change the format. Just login with ssh and run

    sudo raspi-config

    In localisation menu you can set the timezone.

  • I had set time zone when I set up the pi.  It always just shows Universal time (UTC format) not my Local time zone.


  • Will test this as soon as my server works again. Need to finish current mod first to test/modify.
  • Thank you very much.  It really is a bit confusing, local time would make the most sense or a user selectable option.

    Dave
  • Ok, have tested it and found both problems. Next release will show end time in local date format and also compute end time correctly. Last error only happens if you print directly just as I thought might be the reason. Printing already stored gcodes shows right end time.
  • Great Thanks much!!
Sign In or Register to comment.