M190 Bed temp is wrong in GCode


I have installed the new Repetier Host 2.0.5 and get a strange problem when slicing.

;Generated with Cura_SteamEngine 15.01
; Default start code
G28 ; Home extruder
G1 Z15 F600
M107 ; Turn off fan
G90 ; Absolute positioning
M82 ; Extruder in absolute mode
M190 S50                                           This value should be S35...
; Activate all used extruder
M104 T0 S210
M104 T1 S210

I have set the temp of the bed to 35 degrees in printer settings and in the filament settings for the support and the building material.

Still it generates M190 S50 in the GCode...

It is easy to edit but why does it write wrong temp?



  • Good question regarding the fact that it works for me.
    First make sure you also have selected the same filament on the right side as you have defined in cura engine settings. Make sure changes are saved before using them. Also make sure you have not set it to a fixed value in cure engine end gcode.
    It will select highest bed temperature of all selected filaments.

    Hope you see the part where it goes wrong.
  • I found out that:
    I have 3 setting for the filament  , Build (35), support (35) AND default (50).
    So it picked the default value. I change the setting for the default value to 35 and then it worked.

    I also tried to delete the default , but it comes back!
    I have seen some other strange things with the slicer but I cannot recall them right now.

    I have a dual extruder.

  • Important is what you select on the right side as input from the available filaments.
Sign In or Register to comment.