Bed Shape Coordinates

I am using a CellInk Inkredible plus bioprinter.  From the company I got the printer shape coordinates to input into Repetier (V2.0.5) (picture provided).  My problem is that when I use Slic3r (V1.3.0) to create the gcode and go print the, extruder travels to the back-right corner of the bed to begin the print.  I am printing via a SD card and when I try to print the gcodes supplied by the company everything works fine.  I am not able to get a response from the company.

So my question is could this be a problem with the Slic3r bed shape settings (picture provided), and if so what should the proper settings be based on the bed shape settings I have uploaded into Repetier.

Thanks for any assistance that can be provided.


  • I noticed within the gcode that the first steps involve homing the axes...
    M104 S130 ; set temperature
    G28 ; home all axes
    G1 Z5 F5000 ; lift nozzle

    Before the print I do this using the printer itself, so there is no need to redo it, also the gcode is causing it to home the z axis on the wrong side of the bed (sensor is on the opposite side) if that is whats going on.  Not sure if this is part of the problem or not.
  • Why not just set slic3r shape to be correct as a first test,

    You should check the gcode generated and where that wrong move is. It could be part of you start gcode in slicer configuration.
  • I think I figured it out.  I went in and deleted the command to home the axes and to set the temperature (both I do through the printer itself) and that seems to have fixed the problem.  
  • In RH you have set X0 Y0 to be in the center of the bed,this is wrong for a cartasian printer,X0 Y0 should be front left of the bed.
    Set Xmin and Ymin to 0
    set Xmax=130
    set Ymax=110
    bed left=0 bed front=0
    print area depth 110
Sign In or Register to comment.