connect to anet a8 (prusa i3?)

I can connect cura and print objects via the usb port but I would like to use Repetier to send info.
I am using windows7 on a pc connected with a usb lead direct to the printer board . All I get on the log is a list of lines
(n55, n56 etc) usually M105 and asterix with a number after it scrolling up.
Some times I get
communication timeout - reset send buffer block     in red
I go to manual control and get        x command waiting         every time I try to jog. Eventually this goes back to   idle and then back to     1 command waiting     as if it is trying to communicate.
This looks like I have the baud rate wrong but I have tried all sort of baud rates without change?
Anybody know how to set up Repetier to work with the Anet A8?
thanks

Comments

  • I have discovered the baud rate of the Anet is 115200 and repetier is set to that so it is not a baud rate problem. any other ideas would be welcome.
    thanks.
  • Is communication protocol set to autodetect?
    Nxx is the sending side. Do you see any responses in log when ACK is enabled?
  • edited January 2018
    Transfer protocol is and was set to autodetect.
    ack wasn't set but if I set it there appears to be no difference.
    If I go to manual control and click on Z up I get 1 command waiting, shortly after I get

    G1 F3 Z100*10

    in the log but no ack
    I am still getting

    communications time out - reset send buffer block

    in the log.
  • You get that because the firmware does not answer with an "ok" or at least based on settings host does not read it as ok.  The only parameter you can change that has an effect on it is the baud rate and port (in case you have more then 1 port to select from). But having it work with cura should mean port and baud rate is correct. Leaves only DTR/RTS pin that you have no control over since we removed that. Looks like new chips are used for printers now requiring different settings here. Can you say what board you have and serial driver you need to use on windows?
  • Also make sure cura is not still conected
  • I have just finished with the most horrendous problem with CURA so I have deleted it from my computer. Having sorted the problem the computer is now printing from the sd card, when it finishes I will try to connect it without CURA loaded on the computer.
  • No the program loads and works fine till I plug the printer in , it then crashes?

  • edited January 2018
    I have removed Repetier host from my computer and down loaded 2.0.5 without repetier server. The program sees the usb lead and shows a port number  but it has gone back to

    communication time out - reset send buffer block

    If I disconnect and change the baud rate to 250000 When I try to reconnect I get a box in the middle of the screen saying

    the connection failed with the following error The parameter is incorrect

    I take this to indicate that 15200 is fine as no box appears with that, in fact it looks to connect apart from

    No start signal detected - forcing start

    and then

    communication timeout - reset send buffer block.

    I don't have a program to send files to the printer with USB so I would like to solve this.

  • Arduino IDE has a serial monitor you can use. Just select serial port and connect monitor (right top) and you see what printer sends and can also send back commands. At least with ansi baud rates like 115200.

    Make sure repetier-server is not trying to connect. If you have configured a printer there it will always autoconnect until you disable the printer in it's frontend.
  • ?? The anet A8 doesn't use the arduino. It has a dedicated motherboard.
    I assume repetier -server is trying to connect, it keeps sending m105 (get extruder temperature)
    and every so often the log shows communications time out  - reset send buffer block.
  • edited January 2018
    If I open the arduino IDE, open the serial monitor and set it to 115200 it looks as if it communicates with the printer.
    I can send commands with the serial monitor such as G1 Z15 and the Z axis moves.
    It is connected to port 21. Repetier sees this port and displays it in printer settings/connection /port   box but whether I insert that as the port required or just leave it on auto it fails to communicate with the printer.
  • I am using a third party serial monitor and sending and receiving data to/from the 3d printer so I know I am connected but the repetier software fails to see it?
    I have to put a colon after each command, does the repetier manual control do this?
    If I put G1 X20: into the g-code box in manual it fails to see it?
     I suspect the Repetier is not compatible?
    I also know that my third party serial monitor uses 1 stop bit 8 data bits and no parity, what does the repetier use?

  • All printers use 8 bit, 1 stop no parity. I'm pretty sure a8 net uses marlin a firmware. Important is you also select this as firmware or no communication will be possible, especially if you selected repetier-firmware which talks a binary format for better speed. Maybe that is the problem? I know we can talk to marlin with no problems.
  • If I click on the 'firmware type' in the printer settings it stays on autodetect if I click on marlin it ignores me and stays on autodetect.
    It also has now gone back to filling the log with a large amount of information and then crashing as soon as I touch the connect button.
  • edited June 2018
    I know this was a few months ago, but searching and searching the net and this post is the only one that really had the same problems as you did. I did however find a solution.

    The Anet A8 and its variants(like the Sainsmart A8) do in fact use a Arduino clone. Yes you are correct, it isn't a "true" Arduino. It is also a dedicated motherboard using  an Atmega1284P processor running at 16 MHz. 

    I looked at my device manager which stated com 3 was showing as a Matter Control "RAMPS" board, whicg isn't right because I remember working on a few other A8's and they all used the CH340 drivers for the motherboard.
    I then remembered the Arduino software is used to upgrade firmware which I forgot to install on this current PC and after reading post after post of the net someone said it might be the solution...…..

    so I downloaded it and all the drivers that came with it (I felt stupid at this point, noob mistake) and Alas, no luck. Even the Serial Monitor as  stated(in this discussion) would return anything but question marks. 

    At this point I went and got the board info from the Arduio software. It was shown as an "unknown" board, but HA! I have the VID and the PID. VID represents a manufacture, while the PID represents the model of the chip:


    So I searched Bing(yes, I use Bing sometimes) and found these links:




    Tried the first link: https://www.drivermax.com/USB-SERIAL-CH340-wch_cn-USB-VID-1A86-PID-7523-3_4_2014_08-2014-08-08-12053-driver.htm

    Downloaded the drivers:


    Choose "only download this driver":




    Scanned the download a few times to make sure it isn't bad and Eureka! It worked. The printer shows as " CH340 Controller" in the device manger. Arduino software and the serial monitor read it perfectly. Repetier host and server see it just fine. Prints come out just fine. I can even upload stuff to the SD card. Print off of it.  The manual controls are instant. Everything. Now I can even upgrade firmware if I want ;). Hope this helps. 

  • Had the same kind of connection problem with an A8, tried above solution, still no working connection, then came to the simple fix.

    Right click MyComputer--->left click Manage--->Device Manager--->Ports (COM & LPT)--->USB Serial CH340 (COM1)-->Right Click then click Properties---->Port Settings--->Check Bits per second is 115200--> Advanced--> Change COM Port number to COM2 or other available port. Problem solved.   

    Sometimes COM1 is reserved by system so will not allow other devices to use com 1 hence connection issues can occur, changing Port number to 2 or other and ensuring Repetier is looking at Com2 afterwards sorted the problem for me 100% no extra drivers ect were required, Hope this is helpful to anybody having same problem.
  • Předcházející odpověď od Lsmith funhuje i na TRONXY X5S, winXP,win7
    The previous answer from Lsmith also works on the TRONXY X5S, winXP,win7
    o:)


Sign In or Register to comment.