repetier firmware cant print from SD card

i used the

Repetier-Firmware configuration tool 0.92.9 version

to update my previous setup in order to add  a LCD screen support with SD card

the problem is that the display works fine...  i can control  homing , read the sd card  but when i press to print a file from the sd card then the  dispaly shows for few  seconds below that printer is printing and then goes again to the  previous state...  like being in stand by mode...  (no errors appearing ) 

The file i had in the sd card has been sliced with cura engine with  repetier host 1.6.2  i am using

When i am using the usb cable to send the file to the printer.. it works fine and printed

thanks in advance


  • Could be a problem with sd card format or a reading problem. Try formatting sd card with sd formatter and copy again. Also make sure to always cleanly unmount sd card from pc before removing to prevent corruptions. I do not think the sd library is good at fixing errors. If something is wrong it will just stop reading the file and print stops.

    You might also try with host connected to too if there are some messages in log.
  • Ok thanks for the super fast answer :)

    i will try all these you suggested me to see what was wrong... thanks
  • Hi again...

    i tried all above but nothing changed
    i can print through repetier host  but the printer cant print from Sd card

    here is the log file from 2 attempts i tried today

    12:35:33.120 : File opened:ex28byj_fila.gcode Size:1705140
    12:35:33.121 : File selected
    12:35:33.295 : Done printing file
    12:35:33.295 : N30 M114*20
    12:36:12.688 : File opened:ex28byj.gcode Size:1424602
    12:36:12.688 : File selected
    12:36:12.862 : Done printing file
    12:36:12.862 : N44 M114*23

  • Hi and Mery Christmas to everyone

    Still cant make it work with Sd card :(
    I tried different sd cards i had but still nothing...

  • Ok i found what i was doing wrong

    i was trying to print a Gcode file from sd Card (.gcode)  and seems that firmware cant do that

    i saved my file  from repetier host  as  ''Save for SD print''    and i manage to print the file from SD card

    the file now has the extension   .gco

    i my Delta 3d printer that i a have Marlin firmware  i could print the  files with the  .gcode   extension

    Am i doing something wrong and i cant print the  .gcode   files with my  repetier firmware based   3dPrinter?  or it is just like this?  i can use only the  .gco    extension?

    it is not big problem that .. just asking to know
  • No gcode should also work, but long filename scan sometimes be a problem, while 8.3 filenames are better supported. For V2 I will update the sd library to a version officially supporting long filenames somewhat better and hope it goes better then.
  • Unfortunately it doesent work with the short file names... as it is  the  .gcode   extension..

    But this is something not so necessary so i am happy that i found the solution to print from sd card  with    .gco    extension :)

    i love the repetier host  and repetier firmware..   make the build of custom 3d printers so easy !!

    Thanks for the replies / interesting  to my problem

    Ps :  To everyone else reading this..  donate to keep it live  (even small donations like me i think it counts )
Sign In or Register to comment.