Problem w/ RaspberryPi Zero and RepetierServer


I recently bought a Tevo Tarantula, which I have been successfully print with using Repetier-Host.  However since there is no room for the printer in my office I have moved it to another room and have been trying to setup Repetier-Server on a RaspberryPi Zero w/ Repetier-Server to control the printer from my office. I have everything setup, and it appears to be correct.  I can successfully connect to the Repetier-Server, and have setup the printer and the server appears to be connecting to the printer.  But, no commands to the printer respond.  I cannot home or move the motors, and printing does not work.  I am kind of stumped here.  It appears the connection between Repetier-Host in my office and the Repetier-Server on the RaspberryPi are communicating successfully, however the Repetier-Server seems to not be able to communicate over serial to the printer correctly.  All the settings are the same for the serial connection as when I was just using the Repetier-Host on my main PC.  Anyone have any idea what could be going on?  


  • If you use server frontend, does printer status get green or always stop at orange? Sure you selected the right serial port. In linux they are not called COMx. You want one starting with /dev/serial (should only one exist).
  • Also try on pi console
    sudo adduser repetierserver dialout

    seems like that command does not always succeed on install but is required to connect.
  • I tried 
    sudo adduser repetierserver dialout
    no luck with that.

    /dev/ttyAMA0 doesnt seem to work, but I connect on /dev/ttyUSB0.  There is also a /dev/serial/by-id/usb-FTDI_FT232R_USB_UART_AL03P0Y1-if00-port0.
  • I get the following from the console when connected to /dev/serial/by-id/usb-FTDI_FT232R_USB_UART_AL03P0Y1-if00-port0.  But still no control of the printer.

    18:03:06.563: start
    18:03:06.605: echo:Marlin1.0.0
    18:03:06.607: echo: Last Updated: Aug 16 2017 10:12:50 | Author: Zviper89, Migbot Stndrdauto lvl
    18:03:06.608: Compiled: Aug 16 2017
    18:03:06.609: echo: Free Memory: 3813 PlannerBufferBytes: 1232
    18:03:06.610: echo:Hardcoded Default Settings Loaded
    18:03:06.611: echo:Steps per unit:
    18:03:06.612: echo: M92 X80.00 Y80.00 Z1600.00 E100.00
    18:03:06.613: echo:Maximum feedrates (mm/s):
    18:03:06.614: echo: M203 X225.00 Y225.00 Z3.00 E25.00
    18:03:06.615: echo:Maximum Acceleration (mm/s2):
    18:03:06.626: echo: M201 X2650 Y2650 Z100 E10000
    18:03:06.627: echo:Acceleration: S=acceleration, T=retract acceleration
    18:03:06.647: echo: M204 S2650.00 T3000.00
    18:03:06.647: echo:Advanced variables: S=Min feedrate (mm/s), T=Min travel feedrate (mm/s), B=minimum segment time (ms), X=maximum XY jerk (mm/s), Z=maximum Z jerk (mm/s), E=maximum E jerk (mm/s)
    18:03:06.648: echo: M205 S0.00 T0.00 B20000 X15.00 Z0.40 E5.00
    18:03:06.648: echo:Home offset (mm):
    18:03:06.649: echo: M206 X0.00 Y0.00 Z0.00
    18:03:06.650: echo:PID settings:
    18:03:06.650: echo: M301 P22.20 I1.08 D114.00
    18:03:49.164: Warning: Communication timeout - resetting communication buffer.
    18:03:49.165: Connection status: Buffered:125, Manual Commands: 16, Job Commands: 0
    18:03:49.165: Buffer used:125 Enforced free byte:11 lines stored:12
    18:03:49.407: echo:Unknown command: ""
    18:03:49.839: echo:Unknown command: " " (2)
  • Ok, it is now correct regarding communication settings. As you see you you get a response. Please check what you set as firmware. If you have selected repetier-firmware in server printer config marlin will not understand the server. You definitevely want marlin as firmware here.

  • Ah, great.  Its working now.  Thanks for your help!
Sign In or Register to comment.