Extruder only extruding in manual mode after fresh install

XYZ Davanci 1.0A
    - Repetier firmware 0.92
Repetier-Host 2.05
Repetier-Server 0.86.2 V7
    - On Raspberry Pi 3

I thought it was time to update to the latest versions of everything, so I started completely from scratch. I even re-installed a fresh BIOS on the printer. Everything is fresh and new. I love some of the new features I see! I can't wait to use them. One problem though, I can't print anything! The extruder works in manual mode just fine, but printing from slic3r is not extruding. It waits for the extruder to come up to temperature before it starts, like normal. The print head moves as if it was printing, but nothing comes out. I remember having this exact same problem when I first installed a year ago, and I seem to remember the fix was just one simple check box. Does anyone know where this is? I'm open to any suggestions. I've been trying for the last 6 hours, and now I give up. 

Any help or advice is greatly appreciated. 


  • See gcode created if it contains G0/G1 moves with E. If they have A instead you have selected wrong firmware flavour in slicer configs.
  • Good thought, thank you. I did double check that. Here is a brief sample of the G Code. Thank you all again for looking! I am wide open to ANY suggestions that may help. 

    M104 S200 ; set temperature
    G28 ; home all axes
    G1 Z5 F5000 ; lift nozzle
    ; Filament gcode
    M109 S200 ; set temperature and wait for it to be reached
    G21 ; set units to millimeters
    G90 ; use absolute coordinates
    M82 ; use absolute distances for extrusion
    G92 E0
    G1 Z-2.650 F7800.000
    G1 E-2.00000 F2400.00000
    G92 E0
    G1 X84.175 Y88.253 F7800.000
    G1 E2.00000 F2400.00000
    G1 F1800
    G1 X85.928 Y86.774 E2.20854
    G1 X88.080 Y85.981 E2.41708
    G1 X89.260 Y85.875 E2.52479
  • That looks correct. So if firmware i snot in dry run mode (debug options) it should extrude with this gcode. If you can extrude manually you are not in dry run mode.

    Enable logging in server and check for warning and error messages. Sometimes firmware detects a decoupling of heater and sensor and goes into dry run mode for safety and disables heaters. Especially on new printers this happens often due to wrong configuration of required time to rise temperatures.
  • Not related to the problem, but this line looks suspect  Z-2.65

    G1 Z-2.650 F7800.000
  • Good catch. Moves on illegal positions are not executed and below bed counts to this.
  • sure you are not in dry run mode?
Sign In or Register to comment.