Just starting out and trying to get things working

I have just purchased a 3d printer kit. The anet A8.
Before it arrives I am looking at trying to get to grips with the software.
It recommends the Repetier sofware.
I also have one of these 3d stepper motor drivers that I have been running with a gcode reader and the stepper motors run fine

Is it possible to just run this with the Repetier software, i.e. just press the manual buttons and have the motors move.
It looks as if the software recognises the board and gives me the option to run the manual buttons but when I press one all I get is
           '3 commands waiting'  (or however many time I press the buttons with the mouse).
in the blue box above.
Does anyone have any idea what is wrong and can I move stepper motors this way?

Comments

  • Even if I put the same g code instructions that run my other software (universal gcode sender) I still get the
    ! command waiting. After a few seconds it goes to
    idle
    as if it has sent them but the steppers don't move or seem tight  as if they are being moved?
  • edited December 1
    At the bottom of the screen I get
    No start signal detected - forcing start
    and then
    communications timeout - reset send buffer block
    as the blue box goes to  'idle'
    this looks as if it keeps trying to send the command.
    I have reduced the baud rate to 9600 to see if there is any change but there is not.

    Woops, just found how to edit my posts     sorry.
    If I go back to the universal gcode sensor on the same port it works fine.
  • You need to use same baud rate and port and it should work assuming you are running a compatible firmware which I think is the case if they suggest the software.

    x commands waiting mean we send commands but get no "ok" response. Happens normally if baud rate is wrong. Important is to set baud rate in printer settings and not in windows device manager.
  • edited December 2
    Thank you for the reply.

    I am not sure about 'compatible software' I am not using the anet hardware yet, it hasn't arrived but I am using an arduino nano and a stepper board that I understand is designed for 3d printers. The one in my first entry of this thread.

    I have altered the baud rate to that used by the gcode sender 115200.
    The blue box above the manual jog buttons now stays on idle when I press a button.
    The box at the bottom of the page says

    N160 G1 X11 F4800*61
    error: Expected command letter

    It then prints

    N161 m105*33
    error: Unsupported command

    This keeps repeating with the N increasing by 1 and the number after the star being different each time?

    The gcode sender still works fine if I connect that and run a manual instruction, pressing buttons similar to the one in the Repetier software but the Repetier software doesn't move the servo.

    I have just discovered how to enter a program for it to run, put it in one of the round numbered boxes below the manual jog buttons.
    I have entered the same instruction the gcode sender sends
    G21 G91 G0 x0.5
    G00 G21
    and sent it, nothing changes, it appears on the box at the bottom with the same
    error:expected command letter
    but nothing moves?


  • I don't think a nano can run supported firmware. It has only 30kb flash and current releases are much too big for it, so that might be the problem. Repetier-Firmware for example has a size of 90-140kb depending on modules used.

    You also must upload the firmware yourself so you should know what you uploaded. Only firmware that might work is GRBL which is more for CNC then printing and is known to be small.
  • I have the same error. It worked fine until I upgraded to Host 2.4. Then Nothing connected. I uninstalled the new Rep' Host and reinstalled 1.6.2 and now it connects but no commands get through and I get the error "communications timeout - reset send buffer block". What to do?
  • Also error, no start signal detected, forcing start. What's happened?
  • edited December 3
    Repetier said:
    I don't think a nano can run supported firmware. It has only 30kb flash and current releases are much too big for it, so that might be the problem.
    As far as I am aware all I am doing is sending the GRBL lines
    G21 G91 G0 x0.5
    G00 G21
    If I send them from the gcode sender they work, if I send them from the gcode box in the top of the manual control page they don't work?
    I am sending them over the same usb port using the same computer and lead to the same nano, I don't disconnect any leads I just press the connect/disconnect box in the top left corner of the repetier page and corresponding button on the gcode sender page.
    The nano has a small program that invokes a library file that, I assume, just converts the GRBL code into an output that drives the 3d motor driver. I am assuming it doesn't care where the GRBL code comes from, it will still convert it?
    I am now wondering if the problem is that the settings are so far out that it is getting the code but what it does with it is so minuscule that I don't even see it on the stepper motor.

  • For printer firmare us emaximum one G or M code per line. What you write above is not supposed to work in host.
    In log enable ack and commands so you see what gets send and the responses. Host will add line number and checksum and that might also cause problems if not supported by firmware. Never tested with GRBL so can not say how that behaves.
  • edited December 4
    Repetier said:
     Never tested with GRBL so can not say how that behaves.
    Sorry  not GRBL   g-code.
    I tried to send the above commands to the nano via the manual control box in repetier host a line at a time.
    It looks to send the first command as the box along the bottom shows it sent but something is also sending another command
    M105*xx   (xx changes each time the command is sent)
    Do you know what this is and why it is sent every 3 seconds?
    Is it possible to be able to send anything to the nano that the stepper motors will act on through the board pictured above?
    At the moment I can't get repetier host to do anything for me?
    Repetier said:
     What you write above is not supposed to work in host.
    It doesn't but it works from universal g-code sender.



  • M105 is polling temperatures (enabled in printer settings). *xxx is the checksum.
    If ACK is enabled after every command send you should get a OK back from firmware. If not it is not compatible to the host.
Sign In or Register to comment.