Repetier Server and RepRapPro Mono Mendel connection problems

Hello, I recently switched from using Repetier Host to Repetier Server for my printers but I have been having intermittent connection problems with RepRapPro Mono Mendel which uses Marlin firmware and the Melzi 2.0 board.  This printer has worked fine with Repetier Host for quite some time but now with Repetier Server it will occasionally (or most of the time) show a yellow connected state on the dashboard or in the printer settings for this printer.  Sometimes it will connect with a green status of online and will print just fine but not often.  But even when it does, after a while it might slow down or rather pause between printing steps and then ultimately if I deactivate and reactivate it it might go back to the yellow only state.  If I deactivate the printer and then go to Repetier Host on the same computer, it always works just fine, I can control it or print no problem.

I am pretty sure Repetier Server is working okay because I also have a Rostock Max V2 printer connected to the same computer and it will always come on line (green status on dashboard) and print no problems.

The computer I have Repetier Servier running on is a MAC Mini late 2009 so it is an older mac but still runs things fine.  It has the latest Yosemite 10.10.2 OS X software.  I have found that the Melzi board requires the FTDI chip driver which I already had installed but I went to the ftdichip website and downloaded the latest software version.  Strange but after that, it worked for about 3 days.  I was able to use the Repetier Server with the RepRapPro Mendel, no problem during that time but then it started with the connection problems again for no apparent reason.  For now I have moved back to Repetier Host but would really like to use Repetier Server for both printers.

I would appreciate any insight anyone might have regarding this.



  • Anyone else having problems with the Marlin firmware and or Melzi board using Repetier Server?  I have updated to 0.51.1 since writing the above post and still having intermittent issues.  And still my very old version of "Repetier Host for MAC v 0.56" which I mention above still runs just fine with this printer.
Sign In or Register to comment.