z home suicide dive

Hi, I have a Tronxy X3A and I have everything working from the standpoint that everything moves and reacts as it should aside from z home. I have the auto-level start g-code in place and it runs. With my printer x,y in the home position, and my nozzle manually placed above the height of the print bed, I can slice and run a print. The x and y axis move to the center of the print bed, and the z axis moves down until the light on the probe comes on then it moves up then down again as it should to find the height of the bed. Once this is done it goes to the home position again and the z axis does a suicide dive. I have to emergency stop the print... What am I missing here? I have tried to go into the eeprom where the value for z home is 100 and setting the z home to -100, or 300 or 3000 nothing changes the z axis still nose dives. What am I missing here?


  • First of all use dev version. It has many things fixed here.
    Then the question sis do you have z min pin to z probe pin? Required for z min homing with z probe.

    After last measuring it computes a correction to go z probe height down, z home z start distance up, bed coating up insome cases plus correction from rotation. Any of these values can cause a unwanted z move during homing which is I guess what you mean with your problem?
Sign In or Register to comment.