Pi Server changing gcode

Hello, I am still somewhat new to 3D printing, so please forgive me if this is known or there is an easy fix out there.  I did search Google and could not find anything.

I have been running Repetier Server off my PC with no issue.
Recently I put together a Pi 3 server with touchscreen and am running Repetier Server on it.
What I am seeing is the Pi 3 server is not running certain gcode and even inserting some of it's own which isn't in the gcode file.
When I run a 3D print job I always put g32 for auto leveling.  The PC server does this with no issue.  The Pi 3 ignores several lines of gcode.  It will G28 to home all, and then go right into the print job ignoring the auto level or anything else I put in. 

I then tested this with a simple gcode test file.  The PC server works great with no issue.  The Pi 3 server will do g28 and then skip down to m104 s0. 

When I look on the console of the Pi 3 I see it even issued commands I do not have in my gcode like G1 X5 Y5 F4000.  

I even looked in my config file on the SD card of my controller.  Both the config and config-overide files do not have this in there anywhere.

Below is my test gcode that the Pi 3 server isn't doing correctly, however the PC server has no issue with it.

G28 ; home all axes
g1 x15y15z15
g4 p5000
g1 z50
M104 S0 ; turn off temperature
G28 X0  ; home X axis
M84     ; disable motors

Thanks for any help,


  • g1 x15y15z15
    is invalid and needs spaces, also all chars should be uppercase, so
    G1 X15 Y15 Z15
    would be correct version.

    In general windows and pi 3 version are identical in source code and should behave identical with same configuration.

    For debugging you should activate logging and reconnect to start logging. Then run the test gcode and post the log for that block. Maybe you have different event dependent gcodes set? Or did you just export printer config for pi?
  • Hello, thanks for the reply.  I will try to run the code as you suggested later this afternoon.

    FYI, I run a CNC in my shop and it is not case sensitive for gcode and does not care if there are spaces on the xyz coordinates.  My CNC in my shop runs Axis from LinuxCNC.

    I will do as you suggested and report back later.  Thanks for the help.
  • I know CNC variants do not require spaces. Some even do not require G1/G0 on every line, but printer firmwares do:-)
  • Ok, thank you for that information.

    I did make everything capital and put spaces for the XYZ coordinates.  The test code worked every time.  

    So, I guess this isn't a bug and more a matter of I didn't understand.  :)   All is good, thanks for helping.
  • I just tried to print a new file I just created.  It is still not doing the G32.
    Here is the beginning of the Gcode.  Most of this is what Ideamaker puts in for gcode.  The only thing I added was the G4 P1000 for a 1 second dwell and the G32 for auto leveling.  

    M221 T0 S94.00
    M140 S60.00
    M104 T0 S195.00
    M109 T0 S195.00
    M190 S60.00
    G28 X0 Y0
    G28 Z0
    G4 P1000
    G1 Z15.0 F2400
    M117 Printing...
  • Please check the log for this. Since you start it at z=0 it might skip it because it is some error state (meaning being triggered already, not able to deploy z probe, ...)
Sign In or Register to comment.