Unable to Connect: MP Maker Select Plus / Windows 10

Hi All,

I've exhausted the help that google can provide and need some personalized assistance <span>:smile:</span>

Printer:  Monoprice Maker Select Plus
OS: Windows 10
Error: Unable to connect to the printer on Com4 (this is the right com port)

I have not yet been able to connect my monoprice maker select plus to repetier host.  Here's what I've done:
  • Ensure that only HOST is running and that SERVER is stopped
  • Ensured that CURA is not connecting to my printer
  • Plugged printer in with USB - under print settings I see com4 appear and disappear when the printer is plugged/unplugged
  • Set baud rate to 115200 (have also tried stock baud rate - but the internet says this is the rate for my printer)
  • When I click "apply" my printer does reboot
  • Click "Connect" - get error
I've tried different USB cables / different ports with the same result.

What can I do?



  • First try with a serial console software. Arduino IDE has one in toolbar, but there are also standalone versions. If you then connect with your baud rate it shows "start" and you should be able to send commands like "M115" to see which firmware it runs. Homepage doe snot say which firmware they use. so guess some marlin like stuff. 

    What is always a try is 250000 baud. It's also often used and maybe printer is just configured to that baud rate. If you use server make also sure to select correct firmware. Repetier-Firmware is not understood by Marlin.
  • Thanks, I'll give this a shot.
Sign In or Register to comment.