Server wont connect unless restarted

Repetier server refuses to talk to my smoothieboard unless I stop and restart the server with the smoothieboard connected. Disconnecting and reconnecting the printer does not fix the issue - only a server restart.
On the server dashboard the printer shows as connected, but no commands are going through, and the communications timeout error keeps on popping up.
Smoothie always comes up on the same com port, so thats not the issue.

Once comms are established everything runs just fine.

I also find that if I try to go direct to com port from Repetier Host the print always freezes after a few moves - no error messages or anything, it just stops.

By comparison Pronterface works just fine, direct to serial.

Any ideas?


  • What happens if you instead of restarting server just run deactivate printer and activate printer. From connection handling this should be the same as a restart.

    When does the com show up in windows? When you connect port or when you enable printer? And is communication possible when printer is disabled? I have only a smoothieware board for testing and there it gets powered from usb and runs already when com shows up. This is what server expects.
  • I have tried just deactivating and reactivating the printer in the Server, but that doesn't seem to work.
    I have also tried deactivating the printer, unplug / replug USB, and reactivate - still no joy.
    The comport shows up in windows device manager almost as soon as I plug in the USB - my board is powered from USB.
    Repetier said:
     And is communication possible when printer is disabled? 
    Not sure what you mean by 'disabled'.

    The thing is, the Server 'thinks' its connected to the printer - I get the green link symbol - but when I go to the server's printer control menu none of the commands work   ( can't home, jog, or set or read temps).

    So I've just booted my pc, with the printer already connected. The com port is visible in Device manager. Server Frontend shows a green link to the printer. I hit 'connect' on Host and...
    Here's what I see:
    11:03:56.531 : Repetier-Server successfully connected.
    11:03:56.649 : M115
    11:04:12.433 : Warning: Communication timeout - resetting communication buffer.
    11:04:12.433 : Connection status: Buffered:13, Manual Commands: 2, Job Commands: 0

    the communications timeouts keep repeating every 30 seconds.

    Attempting to connect with pronterface confirms that the Server has control of the serial port. It doesn't relinquish control properly when I shut it down either.

    Could this be the Server not shutting down properly when the PC is powered down?

  • If you get these timeouts you are not really talking with smoothieware, you only have the com port connected but they do not understand or get responses. Your timeout is 30 seconds so every 30 seconds server tries to send commands.

    Make sure you have in printer configuration set firmware to smoothieware and also baud rate matches. When I do so and activate printer I get something like this:

    8:40:37.202: ok T:24.6 /0.0 0
    8:40:38.206: N189 M105
    8:40:38.207: ok T:24.7 /0.0 0
    8:40:39.207: N190 M105
    8:40:39.208: ok T:24.6 /0.0 0
    8:40:40.214: N191 M105
    8:40:40.215: ok T:24.7 /0.0 0
    8:40:41.221: N192 M105
    8:40:41.223: ok T:24.6 /0.0 0
    8:40:42.228: N193 M105
    8:40:42.229: ok T:24.6 /0.0 0
    8:40:43.239: N194 M105
    8:40:43.240: ok T:24.7 /0.0 0
    8:40:44.247: N195 M105

  • I already have the config set to smoothie firmware, and the right baud rate.
    Telling the server to deactivate/reactivate the printer I see this:

    10:56:48.036 : Smoothie
    10:56:48.036 : ok

    Which looks like its connected ok, but then I try to home:

    10:57:18.314 : G28
    10:57:19.190 : Warning: Communication timeout - resetting communication buffer.
    10:57:19.190 : Connection status: Buffered:11, Manual Commands: 6, Job Commands: 0
    10:57:19.190 : Buffer used:11 Enforced free byte:0 lines stored:1

    and it fails. 

    If I stop and restart the server, (and do nothing else!) I get this:

    10:59:43.766 : Repetier-Server disconnected.
    10:59:48.087 : "C:\Program Files\Repetier-Host\plugins\RepetierServerConnector\RepetierServerStarter.exe" stop
    10:59:57.099 : "C:\Program Files\Repetier-Host\plugins\RepetierServerConnector\RepetierServerStarter.exe" start
    11:00:06.469 : Repetier-Server successfully connected.
    11:00:06.477 : M115
    11:00:06.801 : ok
    11:00:07.353 : ok T:14.0 /0.0 0
    11:00:08.344 : ok T:14.0 /0.0 0
    11:00:09.443 : ok T:14.0 /0.0 0

    It occurs to me this may be some kind of weird usb driver/win8.1  issue, so I may dig out  a Linux box and see if thats any better.

  • I have the same problem! I have a smoothieware board as well....Its been fine for almost a year right up to the new image... now, if I stop a print for ANY reason except IT finishing it freezes communication and requires a server restart.... Do you guys post old images/? I would like to go back as this make it unusable!!! 
  • On download page is a button "Download older versions" that use old version. But be carefull as 0.85 -0.86.2 had critical bugs.
    I can deactivate and activate and it is there. What in deed does not work on the windows version is unpower the board and then power it up again. Then we get no response from the firmware causing the timeouts also the usb port seems to connect correctly. I wonder what is going on there and why it should have worked in older versions.
    Can you say which version had worked without that problem?
Sign In or Register to comment.