Bed Auto-Level question

Trying to get the auto-leveling setup on my HE3d printer. It comes with the inductive sensor. I have been able to get most of this printer setup, but the auto-level is not yet right.
when I send the G32 to the printer (to start the auto-level process), the bed goes to x-0 y-0 (which puts the z sensor over the edge of the bed so it wont trigger).
Where do i set the measurement points on the bed for the auto-level? I am unable to locate a configuration.h file on my windows system.
Any assistance would be appreciated...


  • I am completely lost now. I see all of the references in this forum for setting the auto leveling functions (in a config.h file) i dont seem to have this file (I am running a windows 10 machine). 
    I have looked in the registry and see nothing that would relate to any of this (i see several software entries).
    Where do i configure the points on the bed that get measured?
    I could really use a bit of assistance here.
  • What firmware is installed on your printer ?
    You may be able to set the probe X Y offsets and also the probeing x-y locations in eeprom ,host has a eeprom editor built in.

  • Firmware version is .92.9..
    I have been hunting the host firmware editor for probing locations and just not having any luck at all.
  • I recommend you use the DEV version, many improvements have been made in the probing.
    However, in RH config tab (top left) you should have a ' firmware eeprom edit' option

  • I have been searching several threads and youtube videos and I am getting lost in all of the data here. 
    I see several posts on how to setup the Bed autoleveling, going through them, they all start the same, then they lose me when they start to talk about opening a config.h file to define the bed leveling points and method (these all seem to point back to the Marlin firmware).

    I have no config.h file and am getting lost in the search for "How do I setup the auto bed leveling with Repetier firmware and Repetier Host"
    Is there a guide somewhere that can walk me through the actual steps for setting this up with this firmware/software configuration. 
    I know conceptually how this gets setup, and i understand what it "should" be doing when i send the code to start the auto level process.
    Where in this firmware / software do i go to actually tell it that I want to use 3 7 or 9 points to level the bed???

  •       <<<link to repetier dev onlive config tool.

    Enable Z probing in the features tab, this will then show the probing section about half way down the page.    repetier probing guide.

  • Thank you.. 
    Is there a configuration.h file located somewhere in the software? Or can it be generated from the existing machine? I am uncertain of some of the settings asked for in the configuration tool.
    So far this is an out of the box installation and I am unable to locate these files / settings.
  • The configuation.h is part of the source code that you download with the online config tool, you then need to compile and upload the source to your printers control board using arduino compiler.
    If you dont have the source code then you will not have a config.h
  • You can set the G32 probing positions directly via the eeprom editor in RH , these are the Z PROBE 'X1 Y1 ,X2 Y2, X3 Y3'settings,  but i still recomend upgrading the firmware to the DEV version.  
  • I had accidentally posted this in a different thread..

    How do you change the measurement points for a G32 S2? (My Z-Probe is on the right side of the extruders)
    When I send the G32 S2, the calibration routine goes to these coordinates
    16:54:51.378 : Z-probe:10.03 X:20.00 Y:20.00
    16:55:01.721 : Z-probe:10.10 X:40.00 Y:60.00
    16:55:12.082 : Z-probe:10.11 X:60.00 Y:100.00
    16:55:22.441 : Z-probe:10.06 X:80.00 Y:140.00
    16:55:32.754 : Z-probe:10.02 X:100.00 Y:180.00
    16:55:44.270 : Z-probe:10.08 X:60.00 Y:20.00
    16:55:54.645 : Z-probe:10.11 X:80.00 Y:60.00
    16:56:05.039 : Z-probe:10.15 X:100.00 Y:100.00
    16:56:15.410 : Z-probe:10.04 X:120.00 Y:140.00
    16:56:25.707 : Z-probe:10.03 X:140.00 Y:180.00
    16:56:37.250 : Z-probe:10.13 X:100.00 Y:20.00
    16:56:47.645 : Z-probe:10.11 X:120.00 Y:60.00
    16:56:58.051 : Z-probe:10.18 X:140.00 Y:100.00
    16:57:08.441 : Z-probe:10.06 X:160.00 Y:140.00
    16:57:18.363 : Z-probe:9.24 X:180.00 Y:180.00
    16:57:29.535 : Z-probe:10.18 X:140.00 Y:20.00
    16:57:39.972 : Z-probe:10.14 X:160.00 Y:60.00
    16:57:49.347 : Z-probe:8.09 X:180.00 Y:100.00
    16:57:58.066 : Z-probe:8.80 X:200.00 Y:140.00
    16:58:04.363 : Z-probe:3.23 X:220.00 Y:180.00
    16:58:12.574 : Z-probe:10.22 X:180.00 Y:20.00
    16:58:22.223 : Z-probe:8.53 X:200.00 Y:60.00
    16:58:31.066 : Z-probe:8.60 X:220.00 Y:100.00
    16:58:39.753 : Z-probe:8.33 X:220.00 Y:140.00
    16:58:48.316 : Z-probe:8.34 X:220.00 Y:180.00
    16:58:52.396 : plane: a = -0.0113 b = -0.0050 c = 11.4768
    16:58:52.396 : Transformation matrix: 0.999936 0.000000 0.011305 -0.000056 0.999988 0.004971 -0.011305 -0.004971 0.999924
    16:58:52.411 : CurrentZ:8.42 atZ:10.00
    16:58:52.833 : Info:Autoleveling enabled
    16:58:54.019 : X:200.08 Y:180.03 Z:5.164 E:0.0000

    It never gets to the back of the bed (bed size is 200 x 280) but the last few measurements put the sensor off the right side of the board so it does not trigger.

    I have set the X1 t0 20 and Y1 to 20
    X2 is 180 and Y2 is 20 
    X3 is 20 and Y3 is 250

    These should have marked almost the front 2 corners and the rear left corner of the bed. 
    The Y axis never went anywhere near Y 250 and anything around X200 puts the Z sensor over the edge of the bed. 
    Do i just need to change the 3 sets of X Y probe points to bring the X down into the bed area and get the Y to go farther to the back??

  • Where is your probe fitted with relation to the nozzle  ?
    X offset  Y offset
    can you post a export of your eeprom settings 
  • The Z probe is set to the right of the nozzles (this is a 3 extruder system).
    I will need to get a copy of the eeprom settings. 

    Right now i have removed the outer nozzles because they were dragging on the print, I am trying to print corner brackets to secure this unit to a board (that's what the temporary straps are for).

    The extruder offsets are setup so that when homed, if i select extruder #1 in Repetier-Host, the far right extruder is at 0,0, if i select extruder #2, the head moves to the right by 1600 steps and extruder #2 is over the same spot where extruder #1 was.
    When I home all 3 axis, the sensor gets lined up with the front edge of the bad and inset as shown,

    This is a picture of the machine homed. 
    Using your suggestion, I set Z PROBE 'X1 20  Y1 20 ,X2 180  Y2 20 and  X3 20 Y250
    This should be 3 points (the first being where the unit homes, the second begin almost to the right edge of the bed and the last being at the left, almost to the back corner).

  • Getting complicated with 3 extruders lol.
    Where is X0 Y0 on the build plate ? where the centre nozzle is in the pic, or at the front left corner?

    Is X20 actually reachable by the probe (probe looks to be at least 50mm offset from the nozzle in the picture)

    As a test, try setting X1 50  and X3 50
  • I have had some difficulty actually understanding which extruder is used for 0,0.
    If i remove all offsets, and home X and Y, the true 0,0 would be physically located (on the bed) in the front left corner (the extruder would then hang off of the front of the bed). 
    I have considered moving the switch for the Y axis forward so that when it triggers, the sensor is over the edge of the bed with no offsets defined.

  • here are my eeprom settings... 
    I had to set the max x to 150 to get the autoleveling to not try to probe over the edge of the board (a bit disappointing as it seems that I will loose the ability to print closer than about 30mm from the edge.. :(

  • edited September 2017
    MartinH said:       <<<link to repetier dev onlive config tool.

    Enable Z probing in the features tab, this will then show the probing section about half way down the page.    repetier probing guide.

     The 2nd link should explain where the coordinates go, because of the offsets, the area available to be probed is less. The printing area is limited to where the nozzles can reach. Based on what I see in your pic, your probe is as far left as it can go so your X coordinate for probing can't be any farther left unless the carriage can physically move farther left. If you home,  then move the active nozzle to the probe location and do a G30, that should give you the probe offset. that is the amount you cannot use to probe on the x coordinate.
     At the left side  you are limited to that coordinate, at the right side you would go off the bed with the probe, so you need to subtract that much from the Max coordinate.
     Unless the probe hits something on the right side it should not limit your printing to the right, The only limits I can see for printable area would be the physical limit that the carriage can move to get the correct nozzle in the correct coordinate. I do not have multiple extruders set up on my printer, but if I were to add another extruder the physical build would limit my printable area. I do not know how the manufacturer takes into account the extra room needed for the nozzle offsets.
    I do not think that most beds need to be probed "edge to edge" to get a good first layer.
    Just remember to try and get the physical calibration for bed-level as good as you can FIRST , then the software doesn't have to compensate as much. You might find you won't need to bed-level using the probe.(maybe).
  • I have looked over the doc in link 2 several times (i have even printed it so i can read it while offline..)
    What I read from the doc is..
    If I set the probe X,Y points so position #1 is 20,20 position #2 is 150, 20 and position #3 is 20,250
    The the probing should use those points (and a grid between these points) to measure and get its measurements.
    If i leave my bed size (X max) set to 200, I can move the X-axis to x200, and get all 3 nozzles to line up over the same point at x200 (from the nozzle offsets in the firmware)..
    When I send a G32 S2 to the unit, the process appears to begin as listed (starting at 20,20), the issue comes in near the end of the process when the probe nears what is defined as point #2 (150, 20), which as i understand means that the probe should not go over x150 during the process...??? 
    What ACTUALLY happens is that the probe goes over x165 (which effectively puts the probe itself over the edge of the bed and will not trigger).
    How can i keep the bed size at 200 (the actual size) and have the probe only go to x150 which would keep it on the bed???

  • edited September 2017
    Is the probe offset correct? X/Y?For example , if you did a G1 X50 Y50 and then did a G30 your coordinates would read X50 Y50? Where is extruder 0? the center one?
  • Extruder 0 is the one on the right. When I home all axis, this puts the extruder unit at 0,0 and extruder #0 as close to the outside edge of the bed as is physically possible, if i select extruder #2 in RH, the head would move to the right.
    in the above pic, this is the home position with Extruder #2 selected.
    yes, if i send a G1 X50 Y50, I have not done a G30 after this, but all displays (on screen and on the LCD) indicate that it is at X50 Y50
  • edited September 2017
    I see a few problems in the eeprom settings.
    You have a probe offset of X20 Y20, this says the probe is 20mm to the right and 20 mm behind the centre nozzle (ext 0)
    From the picture you have 3 nozzles, if we say the centre nozzle is extruder 0 the (guesing they are 40 mm fans)  your probe offset should be around X50 Y0.

    I also see in the eeprom that the probing points are set at
    X1=0     Y1=0      <<<<i do not see how the probe can reach this destination maybe X1=50 Y1=20
    X2=150 Y2=0     <<<<X2 can be the far right of the bed,                                        X2=150 Y2=20
    X3=100 Y3=230   <<<<this should point to the left rear, not the centre rear             X3=50 Y3=230

    Is it possible to move the X endstop so that the centre nozzle when X is homed is at the left edge of the bed,ie 0,0
  • Ok.. I think i understand..
    Ext #0 is actually the far right extruder, so my probe offset needs to be x20 y-20 since the physical probe is 20mm to the right and 20mm forward of the extruder.
    For the probing points, X0 Y0 is where the unit homes to, I moved the Y limit switch so that when I home the X Y, this is where it stops with extruder #1 selected.

    I will change the X3 Y3 to be X3=0 Y3=230
  • i just homed everything... sent a g1 x50 y50 z10.
    G30 reads now Z-Probe:10.20 x:49.93 y:49:66
  • I also measured the paper i was using and changed the z-probe height to .10 and changed the z probe x1=0 y1=0, x2=150 y2=0 and x3=0 y3=255. 
    Now it seems to probe the entire bed with the probe on the bed (i still have the max x=150, would like to set it closer to the 200 so i don't loose the ability to print with ext #3 on the outer edge )
  • ok.. We have progress.. THANK YOU!!
    I now have a "Better" understanding of how this auto level process works and I have reset the bed size to 200x280 and the probe measures only on the bed ( i set the probe x2=166 and that is the edge of the board as the sensor sees it.

    I am getting a bit discouraged though, because the whole purpose for getting this all setup is because I cannot seem to get the first layer to stick, the initial thought was the bed not being level. It was not as i could see the distance get bigger and smaller through the print. 
    Now the distance seems to stay the same throughout, but i still cannot get the first layer to stick.
    This is what I get (and a pic up close of it printing..
    I hope that you can take one look at this and say "Hey.. The problem is...."
    The bed is at 60
    The PLA is a 210 (this is the skirt, brim and the beginning of the raft).
    Thank you for all of your help, it is truly appreciated.!!

    Also (this is after an application of mega firm hold hairspray and letting it dry).. it made no difference at all in what is happening..

  • edited October 2017
    What is your first layer thickness? what is your normal layer thickness? The filament should be a little "squished" onto the bed so it will stick. Do you do the autolevel with the hotend and bed up to temp? The distances can change when heated. If I use 0.2mm as layer thickness, I usually set my 1st layer to 0.3mm and run it at a slower speed.
  • your z offset may be a bit high. lower the Z offset variable. Basically your Z offset should be the difference between the probe (triggered position) and the actual height of the nozzle form the bed when the probe is triggered. adjusting this may get you a better layer height and "squish" factor. I usually run the skirt and while that is running i run my finger over the bead to feel how high tit is - you get a "feel" to know if it is squished enough, too much OR too little
Sign In or Register to comment.