Debug mode runs fine, actual print shifts on X each layer

I have searched here and not found the same issue: Just getting my CoreXY up and running. Have been running prints in debug mode for ~20 hours, no issues. But having an issue with actual printing. If I run a print in debug mode, you can see everything is running fine. But when I run the same gcode for a real print, each layer printed shifts to the right (+X) >10mm. It's just a 20mm calibration cube. Z and Y seem fine, but not X. Plus it will quickly shift to the right so much that the carriage will bump into the X max. Sliced model looks fine.
RepServer Pro, via Raspberry Pi 3. FW created on 1.0.0dev. MKS Base 1.5 controller. 


  • Typical problem of crosstalk. Your heaters induct signals to x endstop and everytime that happens the x move in X- direction is stopped causing it to move to the right.

    Best is to twist and isolate signal cables. In repetier-firmware you could disable endstop testing during print with compiling ALWAYS_CHECK_ENDSTOPS 0 so that this also would not happen.
Sign In or Register to comment.