Extruder heater turns on then quickly off when prompted from Repetier Host

After successfully running my DIY printer with RAMPS 1.4 board and Repetier firmware for 6 months, I decided to upgrade to the newest version of Repetier firmware and now am having troubles heating my extruder. I am using a Discount Smartcontroller from RepRap on my printer and when I attempt to heat the extruder using the LCD, everything works as it should. However, when I start Host and attempt to heat the extruder, I get a "debug level 6" error in the log and the heater turns on for a few seconds then off when I press the heat extruder button from Host. Does anyone have any idea why this is?

Comments

  • It is also worth mentioning that I am not able to manually extrude filament when the extruder is heated correctly. It is almost like the printer is in dry mode but I have it unchecked in Host. Any help is greatly appreciated. 
  • Please check temperature curve in host. It can show what firmware has set as target temperature and the output power firmware tries to send. Depending on this you can narrow down the problem.

    Debug level 6 is just a message from firmware that the level has changed - host does set it on connect so that might be the source.
  • I will attach screenshots of both the temperature curve and the log. The spikes in the temperature curve correspond to me attempting to heat the extruder via host. Notice how the power cuts off very soon after it starts. 
  • Also have a look at the target temperature. You see something set the target temperature back to 0. Enable commands in log to see if a command to do so was send from host side or if firmware did this, also I see no message explaining this in log.
  • I have enabled commands. The log in the attached picture shows the startup connection and then the attempt to heat the extruder. After the M104 command, I don't see anything besides the command to read temperature and certainly don't see something that would change the target temperature to 0. Is the log missing a M109 command to make Host wait until the target temperature is reached? And maybe that is why it is shutting off?
  • Here are the EEPROM and Host settings that relate to the extruder.
  • edited September 2017
    I notice you are using heat manager 3 (dead time control), so in your firmware, what have you set for the decouple time?

    Why not set heat manager to 1 so it uses PID controller

    ps.
    Doesn't explain why it works from the LCD, but is worth trying i guess.
  • M109 makes firmware wait not host. That way it would heat until temp. is reached and then the unknown reason might reappear.

    Just to be clear - you are only setting temperature on host. You have no job running from sd card or host and no other host connectod to a second input like panel due? The few lines you showed in log only show enabling temperature so no reason to go back to 0.

    Also what happens when you set temperature on lcd while host is connected. Does it still work and stay?

  • I only have one printer without a SD card and a computer connected via USB as of now (I usually use Server). When I heat the extruder via LCD, target temperature is reached and held (see attached picture). I changed my heat manager to PID just to verify that was not the issue. I tested my driver for the extruder by exchanging it for the x-axis driver and jogging the x-axis. I also confirmed that the extruder motor worked correctly by plugging it into the x-axis motor output and jogging x-axis. Interestingly, when I upload G-code to host and press start print, the heater turns on until it reaches target temperature and then the print begins. This would be an acceptable work around but                       when I do this, the motor does not extrude. 
  • Strange problem and I currently do not see how you achieve these errors.

    What is when you use the server instead of host - do you get the same problems? If not what about using server vie host server connector?
  • After attempting to print again, I discovered that the extruder motor was skipping. I increased the current on the driver and the extruder is now working properly. However, I am not able to heat up the extruder via the manual control button on Host or Server. Also, when I pause the print, the extruder temperature always goes to 0 thus ruining the print. I am satisfied with not being able to use the heat extruder button in Host but am wondering if a fix is available for the pause issue?
  • You should check your event scripts in host and server. There might be a command setting it to 0. But as long as it does not appear in a log especially the log written to file there should be no reset of temperature at all. And until now you never showed such a command (ok also no complete log). This makes lokating the problem hard, but it seems that firmware somehow does this, also I never experienced this behaviour.
  • I have Board K8200 and i am not able to execute heater in manual mode via heater button. The extruder heater icon is "strangled". When i run the print (automatic mode) then the extruder heater is switched off when the target temperature (for example 190) is reached. The printer ignore heater state and continues in printing.

    I tried in manual mode send commmand M104 S150, where 150 is temperatue and the heater is working, but icon is still "strangled". I am not able to switch temperature using bar in repetier host.

    I tested HEAT_MANAGER with 1 and 3 options without any effect.

    I have repetier
    * host 2.0.5
    * server 0.86.2
    * firmware 1.0.2

    Would you like to help me please.
  • Leave easy mode if you are in i and make sure dry run is not activated. That is the only option making the manual heater commands not work. But that should only happen if firmware is also in dry run so manual sending command manually should also have no effect.
  • edited April 23
    So, testes on Repetier server web page, there is automatic mode running roperly.
    ..firmware is also in dry run s... Where is in the firmware option to disable dry run mode?

    Atached image from automatic (printing) mode.


  • edited April 23
    Top right of your image, above the blue ETE 1h:04m:27s  you should see a 'easy mode' button, turn it off then the DRY run button will appear below the on/off/temperature
  • Manual extruder heater solved, i went back to version 2.0.2 from 2.0.5.
    Now i am able to manual switch extruder heater and change the temperature. On tyhe same FW.
  • Very strange. Just compiled firmware with single extruder like you have and tested and it worked with same temperature report string. I also found no change in relevant code since 2.0.2. Also I agree it is an error I'm not able to replay it. So either I fixed it involuntary or something is strange. But since it is now working in develop version I assume it will still work in final release.
  • And i burned back the Marlin V1 FW.
    Because in repetier was unstable with the extruder heater sensor. About every one hour failed printing
  • edited April 23
    And while i tried to manual switch the extruder heater in Rep. Host 2.0.5 with fw marlin V1 then it is possible.

    Result
    RpH 2.05 is not working properly with RpFw 11.0.2

    I atached my Arduino Project. Which is configured for K8200, you can check it if you wish.

Sign In or Register to comment.