I can connect, but no printer movement

Greetings. I have been using a RP3 running a Repetier Sever that connects to the printer hardware which runs the Marlin FW. This worked fine for almost a year. In fact, it worked fine yesterday and I did not fiddle with any settings. I can still connect and disconnect in the Repetier Host, but when I click "Print", it just stays in IDLE and does nothing. The log says "File uploaded, server response is: {}" and then nothing else happens. Also, trying to move the printer manually is not working.

I can see the printer in the web server, but it says "No Print Job Running."

Any ideas how to get this thing working again?


  • What might have happened is that you have 2 gcodes in print queue. In that case print does only add a new file in print queue, but since it has more files it doe snot know which to start. So go to server tab, select waiting queue and select a file there and start.

    Alternatively go to web frontend and check there for printqueue. Also for testing if printer reacts on manual controls use the one from frontend to rule out communication problems between host and server.
  • A few updates: I see nothing listed in the Server tab before or after I click "Print." I looked on the Web front end, and if I'm looking in the correct spot (Print Tab, Stored G-Codes), I see nothing.

    I think I was mistaken in my original post when I said that I can't manually move the print head using the Manual Control Tab. I CAN. The problem seems to be only starting a print job.

    One other thing I tested: In the web front end, I went to the Console Tab -> Commands -> Show Capabilities, and I got a response that seems to indicate that the RP3 is communicating with the hardware:

    23:13:46.117: FIRMWARE_NAME:Marlin V1.0.2; FIRMWARE_URL:https://github.com/wubbllez/Q3d-Marlin-RAMPS PROTOCOL_VERSION:1.0 MACHINE_TYPE:Q3d One UP EXTRUDER_COUNT:1 UUID:00000000-0000-0000-0000-000000000000

    Any more ideas?
  • I managed to get it working. Here's what I did: Using the web front end, I downloaded the printer settings XML file, deleted the printer, created a new printer, and uploaded the exact same printer settings XML file. I forgot to disconnect from the Repetier Host while doing this, and it crashed when I tried to go into printer settings. I rebooted the RP3, reloaded Repetier Host, changed the printer settings to point to the newly created printer. Just to be sure, I had it create an all new API key and copied that over. 

    Next, I tried to do a print. Instead of just saying "IDLE", it said "Print Job ETA nnnnnn", so it looked like it was working. But when I went to take a look, the printer still wasn't moving. I rebooted everything one more time, and looked at the server tab. This time, there WAS a print in the "waiting" tab. I deleted this, tried to start up a new print once again, and this time everything worked as normal.

    I'm not sure what went wrong, or what fixed it. My guess is there was some weird cached meta-data or configuration that was completely blocking the printing function. I wish there was some kind of "clear cache" button or "factory reset" button in the web front end that could work as a fail safe if this happens again.

  • Maybe of importance here - are you using 0.86.2 as server version? 0.85x-0.86.1 had a bug that could block printing after a finished print due to a dead lock. So if you have one of these versions updating might help here.
Sign In or Register to comment.