Server not printing

edited January 2015 in Bug Reports

Today I tried my very first print after having installed Repetier-Server 0.51.0 for Mac on a Yosemite Server. 
And I was totally disappointed...
The server stops sending the file commands just before the printing should start.
No error message, No warning, Nothing... just stops... with the heater on!!!
You can imagine how frustrating is this thinking that I have already paid for the pro edition...
Of course someone will ask why pay before I try...
Well... I was very confident for the product since I have seen the work of the Repetier team. And because I like to financially support good work.

Anyway... back to the bug.
Following is the beginning of the G-code which is prepared from Slimplify 3D.
Firmware is Marlin updated at the last edition.

M106 S0
M140 S110
M190 S110
M104 S230 T0
G28 ; home all axes
G29 ; Bed Level
M109 S230 T0
G92 E0
G1 E-1.5 F3000
; layer 1, Z = 0.2
; tool H0.2 W0.5
G1 X145.788 Y127.202 F7800
G1 Z0.2 F1002
G1 E0 F900
G92 E0
G1 X148.202 Y124.788 E0.1391 F1080

Right after G92 E0 the process stops.
Following is the last part of the log:
> 15:44:49: echo:Active Extruder: 0
< 15:44:49: N97395 G1 X145.788 Y127.202 F7800
> 15:44:49: ok
> 15:44:49: ok
< 15:44:49: N97396 M105
< 15:44:50: N97397 G1 Z0.2 F1002
> 15:44:50: ok T:230.0 /230.0 B:109.6 /110.0 T0:230.0 /230.0 @:70 B@:127
> 15:44:50: ok
< 15:44:51: N97398 M105
< 15:44:51: N97399 G1 E0 F900
> 15:44:51: ok T:229.8 /230.0 B:109.8 /110.0 T0:229.8 /230.0 @:74 B@:127
< 15:44:51: N97400 G92 E0
> 15:44:51: ok
> 15:44:51: ok

After that it is only M105 commands send to the printer.
The exact same file printed just fine with Octoprint, which thankfully I did not uninstall. (Apparently I was that confident)


  • I'm a bit surprised by this. The server is developed on a mac with yosemite, also I use normally a repetier firmware as other part and had no issues so far. I will test your code I got so far and see if I can see the last line apper. Eventually I need some more lines to get the error depending on what goes on inside.

    But some back questions for clarification:
    - Did server report job as finished?
    - Does repeating the print give the same result?
    - Did the loggin switch back to connected.log ore are all the M105 you taklked about in the job log file?

  • Hi,

    The server did not report the job as finished, it was stuck at 0.9%. 
    I tried it 3 times and the result was exactly the same.
    All of them were in the Job log I downloaded from the server.

    Following is part of the code as seen from the G-code view of the server:

    161M106 S0
    162M140 S110
    163M190 S110
    164M104 S230 T0
    165G28 ; home all axes
    166G29 ; Bed Level
    167M109 S230 T0
    168G92 E0
    169G1 E-1.5 F3000
    170; layer 1, Z = 0.2
    172; tool H0.2 W0.5
    173G1 X145.788 Y127.202 F7800
    174G1 Z0.2 F1002
    175G1 E0 F900
    176G92 E0
    177G1 X148.202 Y124.788 E0.1391 F1080
    178G1 X148.293 Y124.75 E0.1431
    179G1 X171.707 Y124.75 E1.0971
    180G1 X171.798 Y124.788 E1.1011
    181G1 X174.212 Y127.202 E1.2402
    182G1 X174.25 Y127.293 E1.2442
    183G1 X174.25 Y192.707 E3.9094
    184G1 X174.212 Y192.798 E3.9134
    185G1 X171.798 Y195.212 E4.0525
    186G1 X171.707 Y195.25 E4.0566
    187G1 X148.293 Y195.25 E5.0105
    188G1 X148.202 Y195.212 E5.0146
    189G1 X145.788 Y192.798 E5.1536
    190G1 X145.75 Y192.707 E5.1577
    191G1 X145.75 Y127.394 E7.8187
    192G1 X145.75 Y127.293 F1080
    193G1 X145.788 Y127.202 F1080
    194G92 E0
    195G1 E-1.5 F3000
    196G1 X165.61 Y132.853 F7800
    197G1 E0 F3000
    198G92 E0
    199G1 X165.61 Y133.147 E0.012 F540
    200G1 X165.722 Y133.419 E0.024
    201G1 X165.931 Y133.628 E0.036
    202G1 X166.203 Y133.74 E0.048
    203G1 X166.497 Y133.74 E0.06
    204G1 X166.769 Y133.628 E0.072
    205G1 X166.976 Y133.422 E0.0839
    206G1 X167.09 Y133.15 E0.0959
    207G1 X167.091 Y132.856 E0.1079
    208G1 X166.981 Y132.587 E0.1197
    209G1 X166.818 Y132.412 E0.1295
    210G1 X166.714 Y132.342 E0.1346
    211G1 X166.452 Y132.252 E0.1459
    212G1 X166.158 Y132.27 E0.1579
    213G1 X165.897 Y132.397 E0.1697
    214G1 X165.721 Y132.584 E0.1801
    215G1 X165.686 Y132.668 E0.1838
    216G1 X165.61 Y132.853 F540
    217G92 E0
    218G1 E-1.5 F3000
    219G1 X165.61 Y133.147 F540
    220G1 X165.722 Y133.419 F540
    221G1 X165.931 Y133.628 F540
    222G1 X166.203 Y133.74 F540
    223G1 X166.497 Y133.74 F540
    224G1 X166.769 Y133.628 F540
    225G1 X166.976 Y133.422 F540
    226G1 X167.09 Y133.15 F540
    227G1 X167.091 Y132.856 F540
    228G1 X166.981 Y132.587 F540
    229G1 X166.818 Y132.412 F540
    230G1 X166.714 Y132.342 F540
    231G1 X166.452 Y132.252 F540
    232G1 X166.158 Y132.27 F540
    233G1 X165.897 Y132.397 F540
    234G1 X165.721 Y132.584 F540
    235G1 X165.61 Y132.853 F540
    236G1 X150.657 Y132.397 F7800
    237G1 E0 F3000

  • I hope you did wait long enough. Your stop happens at 

    M190 S110

    which is heating bed up and will only continue when bed has finished heating up which takes a while. The files you also see logged should all fit into the  buffer.

    Will test this afternoon anyway, just to be sure.

  • The stop happens way after M190. 
    It is just after G92 E0 at line 176. Both heaters were at full heat and the nozzle at Z0 with the filament oozing like hell.
    So no it was not at the heat bed wait command.
    I had a hard time cleaning the mess after unsticking the nozzle from the bed...

  • Just spend an hour trying to get the error with no success. Since I can nut run your original code (no real printer only a board for testing) I used this code

    M106 S0
    ;M140 S110
    ;M190 S110
    ;M104 S230 T0
    G28 ; home all axes
    ;G29 ; Bed Level
    ;M109 S230 T0
    G92 E0
    G1 E-1.5 F3000
    ; layer 1, Z = 0.2
    ; tool H0.2 W0.5
    G1 X145.788 Y127.202 F7800
    G1 Z0.2 F1002
    G1 E0 F900
    G92 E0
    G1 X148.202 Y124.788 E0.1391 F1080

    Can you test if that still hangs for you. It has the heater and G29 removed.

    The stop you indicated was 11 commands behind the heated bed, that is a number that can be cached, but if you are right the printer has homed and run z calibration until it stuck, right?

    It must be some command you did not show me as you stopped early and maybe missed the command where it stuck or it is a very special problem I do not see or something else differs. My code does not use heaters so testing should be quite fast. 
Sign In or Register to comment.