Kein sichtbarer Mauspfeil

Hallo,
nach dem nun mein Server läuft und auch das Display nutzbar ist, habe ich jetzt schon diverse Mäuse versucht anzuschließen. Diese Mäuse laufen mit anderen Images einwandfrei am Pi. Mit dem Repetier funktioniert es leider nicht. Die Maus löst bei Mausklick ab und zu aus, ist aber nicht kontrollierbar wo. So habe ich leider keine Chance das System über den Server zu steuern. Hat jemand eine Idee was zun ist?

Vielen Dank

Comments

  • Das liegt daran das wir das für Touchscreen eingestellt haben und den Mauszeiger daher entfernt haben. Ist aber leicht zu ändern. Als pi einloggen und 
    nano .bashrc
    eingeben. Ganz am ende steht

    if ! pgrep "xinit" > /dev/null

    then

        sudo chmod 660 /dev/tty*

        xinit -- -nocursor 2> /dev/null > /dev/null &

    fi


    Entferne das -nocursor und nach dem reboot sollte dein Mauszeiger da sein.

  • Vielen Dank, das war es. Einwandfrei.
  • Hallo, ich möchte gerne auch den Mauszeiger aktivieren.

    Leider finde ich in meiner nano .bashrc keinen Eintrag mit

    xinit -- -nocursor 2> /dev/null > /dev/null &.

    Wurde hier die letzten Jahre etwas geändert? Gibt es einen neuen Lösungsweg den Mauszeiger wieder zu aktivieren?

    Vielen Dank. Ansonsten super Programm


  • Ja in neueren images gibt es die Datei /boot/repetier-image-setup.txt - da den wert HIDE_MOUSE auf 0 setzen und neu booten.
  • Hallo vielen Dank. Zuvor startete die Touch Oberfläche automatisch. Nun habe ich /boot/repetier-image-setup.txt - da den wert HIDE_MOUSE auf 0 gesetzt.

    nach dem Neustart fragt er nach einem Passwort. Mit Benutzer:Pi und PW: Raspberrz komme ich weiter.
    Mit welchem Befehl startet nun die Benutzeroberfläche?

    Danke
  • Ich habe jetzt per SSH Befehl StartX eine Anzeige hinbekommen. Sobald ich Putty am PC schliesse verschwindet jedoch auch die Anzeige am Raspberry wieder.

    Bei der Raspi-config kann ich keine Boot B3 auswählen.
    Fehler: The Splash screen is not installed so cannot be activated

    There was an error running option B3 Splash Screen


    Was kann ich hier tun? Danke.
  • Ok, du hast dann nicht das neueste image und update ausgeführt. Irgendwie vergisst er dann die autologin Einstellung, warum wir das auch bereits geändert haben. Wenn das passiert per ssh einloggen und
    ssh rasp-config
    eingeben. Dann Boot Options->B1->B2 
    auswählen und danach sollte es wieder klappen.
Sign In or Register to comment.