Upknown Printer after update to 0.85.2

I have RS running two printers. After updating to 0.85.2 (from 0.80.3), I ran a print on one of them. When the print was done, the printer now shows as "Unknown Printer" instead of its usual name. I ran a print on the other printer next, now that one shows "Unknown Printer". Rebooted everything, still shows the same. I can't seem to get the server to recognize the printers. 
Any suggestions?


  • That is a problem we did not find as it happens only to some users under some timing conditions. What exactly is not clear. Please refer to this thread


    for for to prepare and how you could eventually help us finding the source so we can fix it.
  • I'm going to restore the printers from their backup config files and run another print job. If it happens again, I'll try your instructions from the other thread. Just to warn you, I am very much a novice at linux (like, I need to refresh on how to copy files from the PI to my windows computer), but I'll do my best following these directions:

    Install gdb
    sudo apt-get install gdb
    If it happens log in to pi
    ps aux | grep pi@Felix:/var/lib/Repetier-Server $ ps aux | grep tier
    repetie+   972  0.3  1.7 230756 16552 ?        S<sl Jul08  33:17 /usr/local/Repetier-Server/bin/RepetierServer -c /usr/local/Repetier-Server/etc/RepetierServer.xml --daemon
    pi        1047  0.0  0.1   4276  1808 pts/0    S+   08:04   0:00 grep --color=auto tier
    remember the process id from server here 972 but that is always a different one
    The start gdb
    attach <pid number>
    thread apply all bt
    This will output a dump of all threads running with functions. From this I can get a good overview what is going on and who is blocking who.

    If there is any more explicit info I should know, please let me know :)

  • When you are not printing, you could also try the sequency just to feel comfortable in case it happens in earnest. On second run the install can of course be omitted.
  • Looks like someone was able to get the info you needed in the other thread. I was just able to get the error again (working on other printer issues). Glad you found what you needed, I'm updating today!
Sign In or Register to comment.